Export data from ChatGPT and email issue

Hello everybody! :wave:

I too seem to have experienced the same challenge most people here have reported… (i.e. after upgrading to pro plan, the data export feature stops working as expected.) That said, I bring hopeful tidings! :tada:

After tinkering around on and off with different troubleshooting strategies throughout today, a few minutes ago I succeeded in using the data export feature as usual (email and all). Of course, my solution had to come at what was literally the least methodical couple of minutes of my day. So instead of verifying each step, I jumped around trying several things at once and was rewarded finding a way to get my data exports once again.

So… while I can’t say for certain which step did the trick, I’m happy to share what I think may be the most likely steps I took that may have caused/contributed to the fix:

  • I somewhat accidentally toggled my ‘Chat History & Training’ setting off and quickly then back on when I worryingly saw my chat history disappear before my eyes (nicely, it came right back after toggling the setting back on).
  • I also toggled off the my ‘Web browsing’ and ‘Plugins’ settings temporarily. I may or may not have attempted a data export again at this point, but I have since toggled them back on, so I’m not clear on whether the toggling action or the disabling action specifically were relevant factors.

A few other things I tried that I suspect were less consequential included:

  • Removing the Google Chrome shortcuts (Settings->More tools->Create shortcut) I recently created from my Chrome apps (chrome://apps/)
  • Visiting chat[.]openai[.]com from my mobile device and logging back in after being prompted, which felt a bit like I may have been using an old session (possibly one before having switched to pro plan.)
  • Hard-refreshing the chat[.]openai[.]com vigorously after any settings change ‘just in case’ :joy:

One of my more methodical attempts earlier today included switching to Firefox from Chrome and also trying to use the export feature about 10 times in a row every few seconds. Nothing seemed to come from that, this is specially interesting given that if the feature was merely working in a delayed schedule, well… my inbox would have filled up with several data export download notification emails, which still hasn’t happened.

In brief, toggling off and on the settings, and in particular the ‘Chat History & Training’, could fix this issue. Otherwise, it’s possible (though less likely) that there are times throughout the day in which the feature works as expected and other times when it doesn’t. Or perhaps some miracle worker fixed the issue a few minutes ago? :pray:

In any case… I’ve gotta dash out of here as I still have several things to get done, but I hope this info helps some of you get your data exports sooner, or at least give ya some hope and point you in a better direction.

Cheers!
Arty

2 Likes

update: was able to export successfully again. fine. :slight_smile:

1 Like

@arty Just tried exporting and it works. I haven’t done anything to try and fix it.

So the possibility that it so happended that the fix landed right in the midst of your tinkering seems the most likely explanation.

1 Like

Still isn’t working for me! :frowning: I know it’s a lot of data but it’s still less than 100K

1 Like

Great to know it’s fixed for you too! :raised_hands:

And agreed, a timely fix may have been the game-changer in the end :partying_face:

Works for me now. Big thanks to the development team that fixed it.

1 Like

Started working again for me the day after I posted my first comment.

Not getting email I followed all the suggested steps but had no success. can someone help me to get the data exported, please? I really appreciate it. Thanks!!

1 Like

I have the same problem. I also tried all suggested steps but had no success. Can anyone help, please? Thanks in advance!

2 Likes

I am receiving the email, but after clicking on Download option the page doesn’t load.

It shows some site error

2 Likes

This worked in the past but not anymore. Ive tried almost daily for the last month but no email is received.

1 Like

In my case, Data export does not work at all. What should I do?

1 Like

Similar - Last success was June 3.

Unrelated but significant: I received a “features” update email from OpenAI on June 13

June 2023 - Same here - exporting chatgpt conversations to my email worked perfectly for months, emailing the data within seconds of export. Now it no longer works at all - I tried logging out and back in, clearing browser cache and toggling chat history switch. I’ve had to resort to cut and paste.

Tip: To copy conversations into a document without the formatting and frames –
COPY - ctrl + C
PASTE - Press these 4 keys simultaneously - ctrl + shift + alt + V

UPDATE 6/28 - EXPORT NOW WORKING

I got the same error- apparently it has got to do with the firewall and your network settings. I changed my network to mobile data and downloaded the chat archive.

I have tried everything - for going on 5 months now. OpenAI customer support fails to reply - they’re incompetent and cannot help anyway. This is starting to become an issue. If it’s not fixed at the 5 month marker here in a week - shutting this down and cancelling the account. When you cut-off money supplies to OpenAI, they’ll start doing something and take everyone seriously.

1 Like

I had this problem (I had a lot of historical data), and for me it worked after I deleted a bunch of them. I’m not sure if it was the number, or a specific response, but it worked after clearing out some old ones.

Are y’all currently able to export your chat history? My requests haven’t yielded an email for several months now…

Update: I was finally able to get an export near the end of October.

What is the status of this? This bug has been open for about 5 months.

Just tried today.
NOT WORKING!
Appreciate OpenAI’s work, but…