Exceed current quote error even though i dont exceed it?

Can someone help me i’m using a wp plugin that makes a call to openai api, it’s been working without any issues but march 27th it stoped working and when i check the logs i see this:

  • Using model: gpt-3.5-turbo
  • Prompt text word count: 18
  • Using OpenAI key: sk-proj-ZR**********
  • Using model: gpt-3.5-turbo
  • AI prompt error: 429 You exceeded your current quota, please check your plan and billing details. For more information on this error, read the docs: https://platform.openai.com/docs/guides/error-codes/api-errors.
    OpenAI Failed, setting as pending

I havent spnd a single dime this month and dont know why i get this error as its been working i the past without any issues and without exceeding my quota i have a $20/day but i don’t even reach that per month.

Welcome to the Forum!

Do you currently have any credits in your OpenAI developer account? If the answer is no, then that would explain the issue.

1 Like

doesn’t you pay as you use? and then get charged monthly? that’s how it used to be when it was working in march. Did openai change it to buying credits?

Not anymore. OpenAI migrated to pre-paid billing during Q1/Q2. You can add add funds under Settings > Billing (a minimum of USD 5 is required).

Hmm ok, maybe that’s the issue. I’ll try to add credits and see what heppnds, all though it says “pay as you go” when I go to the billing section

Thanks for your help my friend! it’s working now

1 Like