Error with Permissions-Policy header: Unrecognized feature: ‘document-domain’

Hi, I’m testing my plugin on GPTs. It is sending data to my app and deal with the data. When i tested this without any authentication, It worked well. Checked api connection and data. They are all fine.

And i added Google Oauth login recently on GTPs, it caused an error
“Error with Permissions-Policy header: Unrecognized feature: ‘document-domain’.”

And it seems like keep sending api request but all of them are fail. They just keep refreshing itself.

image

Could you please help me with this?

1 Like

@gyddl123 Same issue. I get this error even on an api that requires no permission or authentication

I resolved the issue. The problem was with the callback URL. It was incorrect. I had created 3 to 4 similar GPTs for testing, which resulted in the callback URL being mixed up, leading to redirection to the wrong URL.

@gyddl123 My team and I work on a plugin that utilizes Google oauth, and we got the exact same issue as you describe. Could you help us resolve the issue?

We tried generating the unique callback URL and it didn’t help.