Error on plugins quickstart: Failed to fetch localhost manifest

Followed step 1-5 from the repo -

Once the local server is running:

  1. Navigate to
  2. In the Model drop down, select “Plugins” (note, if you don’t see it there, you don’t have access yet).
  3. Select “Plugin store”
  4. Select “Develop your own plugin”
  5. Enter in localhost:5003 since this is the URL the server is running on locally, then select “Find manifest file”.

but got an error:

1 Like

I’m continually running into the same thing. I’ll respond here if I figure out a resolution.

1 Like

from the very beginning I have been using ngrok to avoid using localhost.

If you want to go with this route check out

You can open a https tunnel so you can point your localhost to a temp url.

This way you can develop with https AND you can test oauth if your plugin needs it.

If you want to stick on localhost you probably need to enable CORS in whatever API you are using to host the service.

here is an example for express Express cors middleware

Hope that helps

Did you ever bump into this issue while using ngrok?
Could not parse manifest as JSON: Expecting value: line 1 column 1

Found a solution that worked for me on Chrome.

The provided manifest json had an unnecessary comma after the url field here:

  "api": {
    "type": "openapi",
    "url": "http://localhost:5003/openapi.yaml"

Removing it solved the problem (I made a PR for the official repo to fix this).