Documentation for Version 1 of the GPT Assistant API software

Where can I find the documentation for Version 1 of the GPT Assistant API software in the openai module for python?


1 Like

The actual “where” is down at the bottom of the sidebar of documentation.

To use previous methods, you must use an older library such as Python openai < 1.20, as the new version automatically sends the “v2” header.

1 Like

I guess it can indeed be confusing lol :person_shrugging:

I wonder who’s in charge of designing this stuff :laughing:

They should have enough experience with this kinda thing by now, unless they’re doing it on purpose lol

Every API call is under a base URL that has “v1”. For example, for using a text-to-speech model, or /v1/images/generations for DALL-E.

When making the API originally, this path was likely placed with the thought of allowing future versioning, and then, with more and more model interfaces that have been placed on the same base, making any actual API URL switch would become difficult, impacting everything.

The actual API spec is version “2.1.0”. Schemas on Azure which you can specify are versioned by date.

Perhaps there will be no need to send a special header to employ assistants if it ever emerges from “beta”. The use of header to activate it has allowed the previous assistants version to continue in operation without breakage if you change nothing.

I’m having trouble dropping back to openai 1.19.0:
tom@tom-7040:~ pip uninstall openai Found existing installation: openai 1.35.3 Uninstalling openai-1.35.3: Would remove: /home/tom/.local/bin/openai /home/tom/.local/lib/python3.8/site-packages/openai-1.35.3.dist-info/* /home/tom/.local/lib/python3.8/site-packages/openai/* Proceed (Y/n)? y Successfully uninstalled openai-1.35.3 tom@tom-7040:~ pip uninstall openai
WARNING: Skipping openai as it is not installed.
tom@tom-7040:~$ pip install openai -v 1.19.0
Using pip 24.0 from /home/tom/.local/lib/python3.8/site-packages/pip (python 3.8)
Defaulting to user installation because normal site-packages is not writeable
Collecting openai
Obtaining dependency information for openai from
Using cached openai-1.35.3-py3-none-any.whl.metadata (21 kB)
ERROR: Could not find a version that satisfies the requirement 1.19.0 (from versions: none)
ERROR: No matching distribution found for 1.19.0

I should add to this that at one point i did: sudo pip uninstall openai

Yes, you have a system install, and need to sudo (or be adminstrator if a windows install was “for all users”).

I sent over what you must do to ChatGPT for a pretty tutorial:

To install a specific version of a Python library using pip, ensuring that it’s a version lower than a particular number, you can utilize version specifiers in pip. Below is an updated tutorial on how to install a version of the OpenAI Python library that is less than 1.21.0 (where v2 and vector stores were introduced, but after “projects”), including the uninstallation of any currently installed versions. This tutorial also includes steps for both Unix-like operating systems (e.g., Linux, macOS) and Windows.


  • Python: Make sure Python is installed on your system.
  • pip: Ensure pip is installed and up-to-date. You can update pip using the command pip install --upgrade pip. (note by me: this is a last resort and can be dangerous)
  • Administrative Access: Administrative rights are required to modify system-level Python packages, which involves using sudo on Unix-like systems or running the command prompt as an administrator on Windows.

Step 1: Uninstall the Current OpenAI Library

To avoid any conflicts with existing installations, start by removing any installed versions of the OpenAI library.

On Unix-like Systems

Open your terminal and execute:

sudo pip uninstall openai

Confirm the uninstallation by typing y when prompted.

On Windows

  • Open the Start menu, type cmd, right-click on Command Prompt, and select “Run as administrator”.
  • In the Command Prompt, execute:
pip uninstall openai

Type y when prompted to confirm the uninstallation.

Step 2: Install a Version of the OpenAI Library Less Than 1.21.0

After removing the existing installation, you can specify to pip that you want a version of the OpenAI library that is less than 1.21.0.

On Unix-like Systems

Use the following command in your terminal to install the highest available version of OpenAI that is still less than 1.21.0:

sudo pip install "openai<1.21.0"

On Windows

In the administrator Command Prompt, execute:

pip install "openai<1.21.0"

Additional Tips

  • Verify Installed Version: To check the installed version of the OpenAI library, use:
    pip show openai
  • Use of Virtual Environments: To avoid impacting system-wide Python settings, consider using virtual environments for your projects. This can be managed using tools like venv or virtualenv.


This guide explained how to uninstall an existing OpenAI library and install a version less than 1.21.0 using pip’s version specifier feature. The steps provided cater to both Unix-like systems and Windows, with the necessary administrative permissions. Using these techniques, you can manage Python package versions effectively for different projects.

1 Like

This solved the problem. I’m very grateful for your response and the response of others here.

The script I’m working on, by the way, is on the forum board here: My very simple GPT Assistant Walk-Thru

The problem I’m working on now is this:
openai.BadRequestError: Error code: 400 - {‘error’: {‘message’: “The requested model ‘gpt-4o’ cannot be used with the Assistants API in v1. Follow the migration guide to upgrade to v2:”, ‘type’: ‘invalid_request_error’, ‘param’: ‘model’, ‘code’: ‘unsupported_model’}}

It’s caused by the fact that I changed the model spec to gpt-4o. Is there a way to deal with this and as well stick w’ v1 of the openai package?

Also, I noticed some indications from google that there exist tools for automatically converting scripts from v to v2. Is this true?

If I had to guess why gpt-4o is blocked, it is likely that the model lacks the ability to properly use the multiple tool methods for navigating documents with “retrieval”, and its shortcomings and the marketing misinformation about any quality this model has are gravely exposed by failures.

Do you then think the quality is inferior to GPT-4-turbo?

I can see other reasons which might explain why GPT4o doesn’t respond to version one grammar. One is that openAI is unwilling to support both versions in GPT4o. Another is that openAI is pushing people to move to the new version.

The two assistants versions you can select by header don’t dictate use of a different type of model. The major change besides some new parameters is the switch from retrieval to a simplified file search in v2.

The use of “retrieval” in v1 is likely powered by an Azure cognitive search method, not OpenAI’s embeddings. The AI is then given multiple methods to enter a document by result index, scroll through it with pagination, mark interesting passages, back out, enter another document. In multiple turns that basically set your token budget on fire.

gpt-4o can’t even work with multiple turns of assisting with improving code without degrading significantly in quality and repeating mistakes again. That is my speculation of why it is disallowed.