Custom GPTs cant access csv files?

Hello there, new here.

I am trying to create a custom GPT that would read CSV files and allow me to analyze the data but it seems to have troubles doing that because when i upload the file it asks me to upload it because it cant see the file over and over.

I then tried the same files with GPT-4o and I didnt have that issue. Am I missing something (couldnt find documentation on this behavior) or is it a bug?

EDIT:
Interestingly converting the file to TSV seems to have worked.
Seems like GPTs have a problem properly reading CSV files.

I see it create a table in chat but then the file cant be read. I dont see it being the full table either.

I’m experiencing the same issue. I’ve been trying for a while now and it’s not recognizing any of the files I’m uploading. I also tried to link a Google Sheet, which also didn’t work.

I think I found out what the problem was:

You have to enable the Code Interpreter feature in the Configuration section when editing the GPT.

Once this was enabled, i had no issues with uploading.

Also note that when that option was disabled, I was able to upload TXT files but GPT would hallucinate consistently when asked about the contents of the files.