Cmd + S to save on vscode stops working immediately after installing chatgpt macos App

Here’s the repro:

  • Have vscode open with file ready to edit.
  • Install chatgpt macos app. Login to the app. Now that app is setup switch to vscode.
  • Edit a file in vscode and try to save it using Cmd + S. It fails to save.
  • Quit the chatGPT app.
  • Now try saving the file in vscode using Cmd +S. It works.
  • After that you can restart chatGPT app and the problem of using Cmd +S to save does not happen. It only happens right after install.

I followed the macos steps to replace my View->Toggle Sidebar keyboard shortcut for ChatGPT to Option-Command-S : Hide or show the Sidebar.

5 Likes

Having the same issue. Cmd + S doesn’t work in any app while the ChatGPT App is open. Restarting ChatGPT seemed to fix it as you said.

To add clarification to this, VS Code still registers the key binds as they show when you do keybind troubleshooting. You can do cmd+shift+s for save as just fine. The app has to have some key bind set for cmd+s.

I have the same issue :frowning:

I have the same issue.
Restarting chatGPT app fixed it for me.

Also having the same issue in SublimeText.

the same to me, after install chatgpt app and run it for the first time

Fixed in the latest update.

1 Like

Just checked if I’m already on the last version:
Screenshot 2024-05-20 at 12.05.23
But the bug is still present.

I am also facing the same issue,
Apple M2 Max
macOS sonoma

Its bit annoying when one could not save anything using cmd + s
force exiting open ai app resolved my issue.