ChatGPT Desktop: Issue with Apple's autocorrect on Mac

EDIT (June 22, 2024): There is a temporary solution posted by @habedibubu - there is no official fix for this as of version 1.2024.163.


In the desktop Mac app for ChatGPT, sometimes when I write code, Apple will automatically adjust the spelling/capitalization stuff when I don’t want to.

For instance, I want to write:
What do these commands do: ffuf, curl ?

How Apple will autocorrect it:
What do these commands do: fluff, curl ?

It auto-corrects ffuf to fluff.

Similar issues can be found with proper nouns.

Want:
var name = "john"

Got:
var name = "John"


FWIW: I disabled this setting in my System Setting’s already but the setting doesn’t work at all.

Is there a way to mitigate this issue?


Thanks for any insight!

3 Likes

I am experiencing the same issue. Despite extensive research, I couldn’t find a solution.

2 Likes

Same over here… even in other languages like German or Swiss German for instance.

same here - this should be considered a bug

That drove me nuts too. You can disable it by just rightclicking on a word you just typed in the text field and then under “Spelling and Grammar” untick “Correct Spelling Automatically”

6 Likes

Thanks! This did the trick.

1 Like

Should these settings persist?

Thank you so much, I was about to lose my mind.

Same problem here! Slovak / English language.
Very bad user experience.

Same here, very annoying issue.

Same issue. Infuriating when trying to ask a question about anything with acronyms or other non-words.

I started writing “aws appsync” and it autocorrected it to “was a–sync”. Correcting the autocorrections takes more time than writing the entire query.