Chatgpt could not get a response

In today’s version, chatgpt was unable to respond to messages, and after sending a message, I needed to refresh the page to see chatgpt’s reply

H5 has one of these errors, which should be affected, has anyone encountered it?

_app-a4c060ecbc81f5d4.js:26 TypeError: Failed to execute ‘getReader’ on ‘ReadableStream’: ReadableStreamDefaultReader constructor can only accept readable streams that are not yet locked to a reader
at em (_app-a4c060ecbc81f5d4.js:26:2432974)

5 Likes

Same things here.

After sending one prompt, I got:

Error with Permissions-Policy header: Unrecognized feature: 'document-domain'.
_app-502171a9cdb09c3c.js:26 TypeError: Failed to execute 'getReader' on 'ReadableStream': ReadableStreamDefaultReader constructor can only accept readable streams that are not yet locked to a reader
    at em (_app-502171a9cdb09c3c.js:26:2437035)
    at eP (_app-502171a9cdb09c3c.js:26:2439251)
2 Likes

Yes. same error. but I can use gpt with ios app.

2 Likes

The webpage will stuck at “ChatGPT is thinking”, and won’t give any replies.

I can only get the result after refreshing the page and finding the chat history at the left bar.

ios doesn’t have this issue.

My Colleague is not a Plus user, he is using ChatGPT 3.5, and he doesn’t have this issue.

1 Like

Same here.

TypeError: Failed to execute ‘getReader’ on ‘ReadableStream’: ReadableStreamDefaultReader constructor can only accept readable streams that are not yet locked to a reader

2 Likes

In most cases, you can simply wait a few minutes and try again. If you’re still running into problems, it’d help if you can try these steps first to help us figure out what might be going on:

  1. Try clearing your browser’s cache and cookies
  2. Disable VPN (If you are using one)
  3. Use an incognito browser or a different internet browser/computer to see if the issue still persists, as a security add-on or extension can occasionally cause this type of error.
  4. Disable cookie blockers
  5. Try connecting to another network

Steps for self-check according to supporters, but actually I still not able to get the real-time response.

Same issue for me…
I have disabled all Extensions, Tried incognito mode, tried using different browsers and still nothing… Clear Cookies, cache, local storage.
If I update the page i see the response, but I always get the error
Failed to execute ‘getReader’ on ‘ReadableStream’: ReadableStreamDefaultReader constructor can only accept readable streams that are not yet locked to a reader

1 Like

Same problem also. Tried several browsers, different WiFi networks, with and without VPN, clearing cache and cookies, disabling all extensions, incognito mode, restarting my machine. This issue has persisted throughout today. But I’m seeing a websocket error:

_app-502171a9cdb09c3c.js:26 TypeError: Failed to execute 'getReader' on 'ReadableStream': ReadableStreamDefaultReader constructor can only accept readable streams that are not yet locked to a reader
_app-502171a9cdb09c3c.js:26 WebSocket connection to 'wss://chatgpt-async-webps-prod-southcentralus-0.webpubsub.azure.com/client/hubs/H_dXNlci1LQ1ZuMXNvMVp3a0RuRjdYTGFtUm4zWGg_?access_token=xxxxxxx' failed: 
_app-502171a9cdb09c3c.js:26 Uncaught (in promise) Error: [object Event]
1 Like

I resolve my problem with disabling “Privacy Badger”.

1 Like

I don’t have it installed in my Browser… This is driving me nuts

oh, genius. I did everything I could think of before searching google with that error message. The issue was definitely “Privacy Badger” for me as well. I had chatGPT not working in chrome on 2 different computers with 2 different OS. When i removed “Privacy Badger” it started working immediately. Thanks @barisx

I think that they changed something. This morning it is working fine for me on both Firefox, Chrome, and Chromium (all under Ubuntu)

Erratum : it is not working anymore now. on all browsers. it has bee working few minutes.

Same problem. I use firefox and vpn.
On googlechrome and another vpn everything works.
Never used Privacy Badger.
Could it be some kind of built in privacy_blocker in firefox?

(cache cleaned)

In my case the problem was in firefox. in another browser everything worked fine.

In Privacy Badger, source “chatgpt-async-webps-prod…” is usually blocked but if you set it to only block cookies, it should work.

Could be nice with an update from OpenAI… Since there is multiple people who have til problem, but there is no information to find anywhere…

Tried it out and indeed disabling Privacy Badger helped me out as well.

1 Like

I use the firefox without Privacy Badger
On today and yesterday, the state continully shows

Okay, it can respond today.

But after the second prompt, I always get “Conversation key not found. Try starting a new conversation.”

So weird.
This issue is consistently reproducible.

1 Like