ChatGPT Access Denied on specific machine

I have no problem accessing ChatGPT on my PC. I also subscribed to Plus version and also write my own desktop GPT app based on GPT-3 API and embedded chatGPT web page in that app…
Everything works…

However, when I decided to test the app on my other machine (laptop) I got:
# Access denied
You do not have access to
The site owner may have set restrictions that prevent you from accessing the site.

Initially I thought I did something wrong in my app so I tried in Edge browser, using:

and I get this:

Then, I logged in to OpenAI with my OpenAI credentials, but getting the same thing.

At the same time, I can access the Playground without any problems on my laptop (same machine)
Any ideas?

You most likely have some strange things going on with your laptop and/or browser that is being caught by Cloudflare. The same happens to me if I try to load the page in responsive mode.

Any weird things you’ve done? such as mobile mode, certifications, headers, anything really

ChatGPT is very sensitive to the browser/network identification data (like all other OpenAI APIs). Check if your laptop is using a VPN. If that is so, turn it off. Check if the laptop’s browser is using an extension making User-agent spoofing to emulate browser identification. If that is so, turn it off as well.
Assuming it is a Chrome-like browser, ChatGPT is not quite into “User-Agent Reduction” that was fully applied in Chrome 101 (currently it is 110) - it is suggested to take a look in “Network conditions” in Developer tools and check if the User-agent is using the browser default. You can also see in the Issues tab some User-agent reduction-related errors but they will not stop from accessing the ChatGPT.

1 Like

That explains it! Thank you for the insight.

1 Like

Problem solved: it was VPN - apparently OpenAI did not like it…may be Norton was pointing to some other country…

1 Like

To be precise, OpenAI uses Cloudflare and Cloudflare detects VPNs, proxy servers, TOR endpoints, etc.