ChatGPT-4 missing upload button (solved, confusing UI)

You need to select the Advanced Data Analysis model to use it.

1 Like

Got it. Thanks. I missed seeing that Default and Advanced Data Analysis were selectable options.

“Code Interpreter” / Advanced Data Analysis STILL not available to me as a Plus subscriber. Confirmed there is no toggle to enable it within the Advanced Data Analysis section


Still missing the upload button, and there is no “ Advanced Data Analysis“

1 Like

Old help:

To enable code interpreter:

  • Click on your name
  • Select beta features from your settings
  • Toggle on the beta features you’d like to try

I can find no documented limitation on deployment of code interpreter aka Advanced Data Analysis to plus users. If it is not there, I would contact with a message via, and see if there is a reason for it not being enabled.

(PS, Enterprise can switch access off for their users)


I have exactly the same problem From iPad Pro, M2

My previous +attch files button changes to attach images. I cannot upload files. Could you tell me how I can upload file?

This is previous attach files button but it is gone now.

If you can attach images, the mode selection of the conversation was set to normal GPT-4, and not GPT-4 with Advanced Data Analysis (code interpreter). You can start a new chat, select from the gpt-4 drop-down, and see if you can’t engage the AI in some questions needing it to write code.

hi - i am having the same issue. i have paid $20 per month for GPT 4 Plus. It only allows me to upload jpg / images. I want to upload a csv file for analysis.

Uploading data files for the AI’s python sandbox is only in “advanced data analysis”, which is a mode of GPT-4 that must be enabled from the beta features settings, and then chosen as a new conversation mode from the GPT-4 dropdown.

I also just sub’d to GPT4 recently and am having an awful UX. No access to DALLE3, log ins sometimes take me to GPT3.5 without the ability to slide over to GPT4, upload image icon there but cannot upload anything, Advanced Data Analysis toggle not present during GPT4 hover over only Default, Browse with Bing, and DALLE3 (does nothing when selected).

Mac Sonoma 14

Chrome Version 118.0.5993.117

I am not able to upload a file despite changing all the settings.

1 Like

same here, i can’t upload any pdf file

when I use gpt4 I can see the attachment option ,
but when I chose plugins section it disappears :