Chat History OFF = "Conversation key not found" error

Every time I start a new conversation with GPT4, the first message goes through without issue, but the second message always results in the error message “Conversation key not found. Try starting a new conversation.”

After testing this phenomenon under various conditions, I have concluded the following:

  • It can happen on any browser (so not browser-related)
  • It happens even in Incognito mode (so not extension-related)
  • It appears to be specific to PC browsers; everything works normally on mobile, even with Chat History off
  • It does NOT happen when Chat History is turned on

I find it very strange that turning Chat History off results in conversations suddenly not working. I have reported this issue to OpenAI, but have yet to receive a reply. As it stands, I am basically being forced to share my chat data with OpenAI in order to use the bot, which, as a paying customer, is completely unacceptable.

Has anyone else experienced this issue?

31 Likes

I do not have the noted issue.

Using Chrome on Windows.

The part of the completion after the code block in the second instruction is unexpected but not a show stopper.

1 Like

Thanks for the input. Strange; could this possibly be an account-specific issue? I can’t think of anything that would result in this specific error, though…

3 Likes

Have you used F12 to look for additional errors or messages?

Are you using a VPN?

Have you checked the Related Topics section list at the bottom of the page?

2 Likes

I am not using a VPN. None of the related topics seem to address this specific phenomenon.

For reference, I am attaching two photos showing the results with Chat History ON vs Chat History OFF. The prompts used are exactly the same as the ones you used in your test.


As for the F12 error log, I did notice the following error:
“Error with Permissions-Policy header: Unrecognized feature: ‘document-domain’.”

I don’t know why switching Chat History to OFF would result in errors that do not occur with Chat History ON, however, since all other conditions are exactly the same in both cases.

Any additional insight your team could provide would be much appreciated. If this is an account-related issue that I am unaware of, I hope that this can get escalated and investigated as soon as possible.

4 Likes

FYI

I am not an OpenAI employee only a user like you who also happens to be a moderator on this forum.

1 Like

I suspect it’s likely an unknown error.

It appears that whether the error is reproducible or not might differ from one account to another.

I tried searching for “Conversation key not found. Try starting a new conversation.” on Google, enclosing it in double quotes, but this thread was the only result that came up.

When using F12 for an existing example that error did show up.

To narrow down if the error is related to the second completion did this.

  1. Start with ChatGPT open in Chrome on Windows with History off.
  2. Open Dev Console with F12
  3. For ChatGPT clicked Clear chat
  4. Entered first prompt Write Python for a Hello World example.

Did see the noted error: “Error with Permissions-Policy header: Unrecognized feature: ‘document-domain’.”

  1. In the Dev Console where the messages are using right click → Clear console
  2. Entered second prompt Change Hello World to Nice to meet you.

Do not get any error messages in Dev Console.

1 Like

Ahh, gotcha. Sorry for the misunderstanding, and thank you for your assistance.

1 Like

I do think you have a reproducible problem on your system. I just can not reproduce it so can not help. :slightly_smiling_face:

1 Like

Recently, there have been numerous issues with the front end, and I personally think they may be related to several events, including the introduction of the new pricing plans.

I am aware that various errors are occurring.

I hope your problems will be resolved soon!

I have exactly the same problem. Mac OS, desktop, Chrome browser.

Tried emptying cache, switching browsers, etc., nothing works.

2 Likes

Same here. Ubuntu, desktop, Chrome & Firefox. Clearing cookies etc. not working

1 Like

Clearing the cache and cookies made it such a hassle to log back into other sites, lol.

But I think it probably has something to do with the team plan.
I’ve also contacted support. They’re likely dealing with it right now.

I think they have a pretty good idea of what the issue is and are working on fixing it, so we might have to wait a few more days, but it should be resolved, I believe!

1 Like

Looks like I’m not the only one experiencing this issue after all. I got a response to my inquiry from OpenAI Support; at the very least, it looks like they’re aware of the problem and working on it:

Hello,
​
Thank you for reaching out to OpenAI support.

We are sorry to hear about the issue you’re experiencing with the ChatGPT service and appreciate the extensive testing you have conducted to narrow down the problem. We would like to check if you are still experiencing the same issue. If so, please ensure that your operating system and browser are up to date, try to refresh your browser and clear your browser’s cache and cookies to troubleshoot the issue and system restart.
​
If the problem persists, please provide us with the following information:
- The error message and code you received
- Another screenshot as a reference
- Any other relevant details that may help us diagnose the issue
Providing this information will help us troubleshoot the problem and gather feedback to improve our service. We understand the importance of being able to use our services without compromising your privacy settings, and we want to assure you that we are treating this matter with high priority.

Best,
Dondee
OpenAI Support

4 Likes

I am also experiencing the same problem with different browsers.

2 Likes

have started to get this message this morning. Same situation (running on Edge/W11)

Update 01/Feb : This is now working, no longer getting the error message.

Update 02/Feb: It’s back

The problem temporarily disappeared for me yesterday, but it’s back again today. I’m waiting for an update to my support ticket.

Hi all, I’ve done a bit of searching… as far as I can tell, document-domain is an experimental feature, and has to be specifically turned on for Edge (and maybe other browsers).

What this is for I have no idea! I have no experience of this, so be kind!

There are instructions here: Permissions-Policy: document-domain - HTTP | MDN (mozilla.org)

But, I’ve not managed to get it to work yet!.

This is what I’m trying to do:

  1. create a shortcut to Edge on the desktop
  2. Adjust the command to add --enable-blink-features=ExperimentalProductivityFeatures as a command line option

Use that to run ChatGPT

If I get it working (or not) I will report back.

I’ve experimented with this, and, as far as I can tell, that makes no difference.