Can't change monthly usage limit, "must be on a paid plan..."

I have hit a $10 monthly usage limit but cant seem to change this limit…

I have approx $50 credit in my account, However i got an email saying ‘Your API usage this month has reached your account’s monthly budget of $10.00’ and the API is now no longer returning data. I am on ‘Usage tier 2’ and reading the docs it says i should be on ‘$500 / month’. I cannot find anywhere in my account to increase my limit from $10 to $500.

Email I received:

Account showing as Usage Tier 2, with some mystery reference to ‘arrears billing’ which I cant seem to find a setting for:

Docs showing there should be a $500 monthly usage limit

Any help would be much appreciated!


“You must be on arrears billing to manage usage limits”: looks like this limits page that another also discovered is then rolling out to more users.

It seems a massive oversight if they didn’t think “what about the monthly limits previously set that can no longer be altered?” - getting your account shut off for the month at day 8 because of a setting you now can’t access!

Worthy of immediate escalation, so I will pass it along.

You should also contact via the “help”, and have staff support manually set your monthly hard limit to the maximum you might ever use, explain the new UI that won’t let API developers see the previous setting still in effect.


Yes, got the same message today for no reason… not sure what is going on…

Yea, same issue for our organization. We are tier 5 and cannot modify our usage limit (soft or hard limits). Any idea?

Same problem here. Has anybody tried if canceling your plan and resubscribing helps? Or will you lose your tier doing that?

You don’t “subscribe” to an API account, although your ChatGPT and API are connected to the same login.

The only equivalent would be “deleting” your whole account, making the phone number and email forever unusable for making new OpenAI accounts. Don’t do that.

It seems this replacement message (where there were user-set monthly limits, apparently still in effect even though you can’t see them) is something being placed on the account types that must purchase prepaid credits for API (as opposed to accounts billed at the end of the month from before August 2023). A new account would have the same - and would be more likely to have any new restriction placed on it.

The solution would be to flood the “help” widget with dissatisfaction and the need for OpenAI staff to set new user hard limits. Maybe in bulk OpenAI will see their nonsense-of-the-day is undesirable.

There is “cancel plan” though in billing. But I haven’t tried it.

This does not work. You can simply re-subscribe but it does not display the usage limits. My tier 5 organization is still in the dark as to what our monthly usage limits are and I cannot increase the preset amount… this is becoming quite worrying as we have client SLA’s that we need to maintain.

1 Like

Oh boy, and you’re not hearing from OpenAI?

Nope. No response. I’ve reached out multiple times at this point.

1 Like

I have a second account where the monthly budget setting is available as usual. Do we have any idea what caused our accounts to be in the buggy state?

I also have a personal account where the budget was available yesterday, but now it’s gone. Very perplexing.

Are you guys exploring azure as an alternative? might be worth looking into as a backup solution, especially if you have clients on the line :confused:

Microsoft has been pretty responsive lately, but it’s always variable.

Yeah it might have to come to that. We’ve dumped thousands of dollars into our GCP tech stack so it won’t be a light decision…

Ah, doesn’t have to be this drastic. Just set up your OpenAI nodes on Azure, and consume them from the GCP as you would the OpenAI api.

I’m just suggesting you start checking it out now so you have it in your back pocket if or when you need it.

I have the same problem. Any ideas on how we should proceed to solve it? Thank you

No response from OpenAI on this issue.
It’s almost like they need an AI Assistant to attend to users’ issues.

@gardiner.daniel has your issue been resolved, or does the limit you’ve hit persisted?

It may be that an immediate lifting of all previous user-set limits was put in place after recognizing the oversight. With a communication blackout on these changes (which no user would desire.)

There have not been further reports of API users cut off due to an existing limit. However the loss of utility by removing the ability to limit consumption is apparent.

Maybe OpenAI was tired of tech support for users who caused a 429 “check your payment plan” error for themselves with a forgotten setting for a monthly limit. There’s plenty of support requests here where the solution is “your account balance is $0.00”.

I also have the same problem. I am a new user, but I was previously able to change the limit as usual.
Currently, I am tier 3, but according to usage tier documentation, I should be promoted to tier 4 soon (just hit the 14-day requirement). That’s a shame because due to this problem, I can’t even increase the limit to what I should be eligible for. Did anyone get the issue resolved?

1 Like

@_j strangely the API is now working again, I don’t know what caused this. I did ‘Cancel plan’ and then add further credit but not sure if it was this that got it working or something else behind the scenes. Either way I don’t necessarily trust this won’t happen again next month when I hit the $10 monthly spending limit.