"Cannot have multiple custom actions for the same domain"

When trying to save my custom GPT I see this error in the console:

"Cannot have multiple custom actions for the same domain"

I’ve only added one domain with multiple (different) actions. Seems like a back-end bug where it’s trying to save a new domain, rather than updating the existing one.

Gizmo id: g-MoIEVFM2O

OK, looking at the request data it does seem like it included all actions twice for some reason. So maybe it’s a front-end bug

Some other tools are repeated too:

I’ve started seeing the same issue today too, it was OK until about three hours ago (or so).


This happens frequently and I think this is defect. My solution to this is deleting actions. After I delete actions it is not giving this error and I am re-adding it with my other changes

1 Like

I’m having the same problem and it’s bothering me. Let me try your solution. Hope chatgpt fixes it soon

I also started seeing this yesterday, which is quite annoying.

It appears to happen randomly when making changes. Deleting the actions and adding them back from scratch fixes it.

1 Like

The error in the UI is simply “error saving draft” that error comes from digging into the console.

I can’t update my list of actions to call.

Please fix it.


same issue here. Its stopping me from being able to save any changes to the gpt including being able to remove the openapi schema so im stuck in a perpetual frozen state.

1 Like

Experiencing the same. Feels like a FE bug.

I started experiencing the same issue about 3-4 hours ago.

1 Like

This bug was resolved for me tonight. I was able to delete the duplicate action. (wasn’t showing up before.)


Fix confirmed, it’s working for me now. Thanks!


having issues with custom actions - would love some help?

1 Like

error i am getting… Cannot have multiple custom actions for the same domain… what do i do?


Hi. Has this error been solved?
I am stuck and cannot update one of my GPT’s

Same error **Action sets cannot have duplicate domains **. I think it’s reasonable and fair to use the same domain for different actions.

I’m in the same boat. Same domain - calling multiple interconnected services from different modules of an ERP system, so we need this functionality to add multiple domains - at least for the organization of the tasks.

Do we know if this has been addressed somehow as a request?

I got the same, i have trying to create two actions from Make. Still get: “Action sets cannot have duplicate domains - hook.eu2.makecom already exists on another action”

Any progress someone?