Builder name not displayed

I can’t make gpt’s public. I think it’s due to the builder name being missing based on other posts I’ve seen. However the others were resolved by turning the builder name on. I don’t have that option see below. I have a name in all the account settings and billing settings I can find. I’m a plus member and have a successful verified domain.