Assistant still refers to the RAG input file

Yo guys, I’m trying to set up an assistant to function as an HR employee and respond to emails from employees or potential employees. I’m having trouble configuring the assistant not to mention the input file for RAG in responses. Any advice on how to set this up? Whether to specify in the assistant settings in the “playground,” directly in the input file for RAG, or to upload a separate file with instructions to RAG on how to behave?

Question: What is the workplace?
Answer: According to the file you uploaded, the workplace is at the company’s headquarters.

did you try to add in the instruction something like: never mention anything like “according to the file you uploaded”?

Of course, it´s not working. Same problem.

I might have mentioned that the settings and communication are not in English but in Czech. However, that shouldn’t be an obstacle.

lol i had the same problem. this ‘prompt engineering’ worked for me: “this is the time data of my direct reports. don’t acknolwedge this message in your next reply. Strictly follow this instruction. This is important to my career.”

In my case, I’m attaching a file for use with code interpreter but you cant attach the csv file to a thread directly - you have to create a message in the thread first then attach the file id to that message.

It looks like emphasizing the instruction ‘strictly follow the above rules’ helped.

1 Like