API key created but not showing in /api-keys gui

Hi all,
I’ve created 3 API keys of which I am successfully using one, so that confirms that they exist. However they are not being listed in https://platform.openai.com/api-keys. The page continues to say “You currently do not have any API keys”

Without them being listed I am unable to manage them such as ‘delete’

Steps to reproduce:

  1. create new key
  2. newly created key not shown in gui but useable in api

I have billing setup and am being charged as expected
I have tried the following:

  • clear browser cache, incognito browser, other browser - same issue
  • called the API using different models - that hasn’t fixed it

Anyone else seen this and fixed?
Thx

1 Like

Issue resolved in the background. Maybe this post triggered the fix :woman_shrugging:

Hello, because the issue was solved I would appreciate if you would mark your post as the solution. :smiley:

1 Like

Hello, i have same error. It seems not been solved yet.

We’re running into this issue as well.

Is there any way to manage keys outside of this (broken) UI?

We’ve provisioned keys that we can no longer see, and therefore can no longer manage :worried:

I’ve come across a similar issue. I can’t see all my created keys, but I use them. I have only one organization for my account, I’ve tried different browsers also, tried to clean all cache and it didn’t help. The problem isn’t solved yet.