Some API Keys disappered from list

I can’t see some of my previous API keys. I generated them for different purposes and I see all of them in statistics and I can use them but not in the keys list. I’ve tried to refresh the page, used different browsers, etc. If I create a new key then I see it in the list though.

They are likely gone from your organization because they were detected as leaked. Found in code repositories, or in client code on app stores. OpenAI saved you from abuse.

Review the practices that you are using to employ keys.

But these keys weren’t disabled or deleted, I can use them right now. And I can’t even delete them if I want. I didn’t use them in public repositories as well.

In my case, since I chose “individual” for the question “Who does this account represent more?”, the same API key is displayed on the OpenAI platform whether I select “individual” or “organization name”.

However, if “organization” is chosen as the representative of the account, it is possible that different API keys will be displayed when switching between “individual” and “organization name” on the platform screen.

Another possibility, as mentioned above, is that the API key could be hidden if a risk of misuse is detected.

If you can’t find the API key, why not try switching between the individual and organization name options on the OpenAI platform screen to see what happens?

You can also look to see if you have multiple organizations, or even logins, with another also being funded.

At, at lower-left you click on your name, and should get a pop-up menu. There will be a checkbox next to your chosen organization, and some accounts may have multiple created for them by OpenAI (such as an extra “personal”) even without being invited to a company.

Then go for the big hard-refresh, holding shift-reload or ctrl-reload or different browser.

If there is something you just can’t discover where the keys come back or can be deleted, and it doesn’t magically fix itself, then the next option is “help” in that menu to send a message.

1 Like

No, there is only my account and one organization. And I’ve tried refreshing and other browsers at first.
chatgpt-acc-organization-2024-04-15 15-18-01

If you are unable to find your API key even after switching between organization and personal accounts, and yet the API key remains accessible, it would indeed be confusing.

If you are certain that you are managing your API key (and it has not been leaked), then it should not be misused or have its credits used without authorization.

Nevertheless, if the API key does not appear, it can be confusing because you cannot manage, disable, or view them.

In such cases, it would be more reliable to contact support for a solution rather than searching for one here.

Nevertheless, if the API key does not appear, it can be confusing because you cannot manage, disable, or view them.

Year, that’s my problem, you’ve got me right. I’ve written them also from “Help” menu yesterday, but they haven’t fixed it yet. They just gave me the same advice as you. Perhaps I should just wait.

A similar thing has happened to my API keys.

I recently created 4 API keys in my user account within my organisation.

They have all disappeared, yet they are still working. I can also see them being used in the Usage section of my account.

I have no way to edit, delete or disable them.

I have just created a new API to see if that is displayed which it is. However, the delete button is disabled on it.

Chat support also have not responded to me.

I would really appreciate any help. Thanks

It seems that the method of managing API keys has changed, and the transition from user API keys to project API keys has begun.

I was having trouble because my API key was not displayed, but when I clicked the “View User API Key” button on the API key management screen, the API keys created in the past were displayed.

“User API Keys” are shared across the entire account, while “Project API Keys” are managed separately for newly created projects.

If you cannot find the API key that was displayed before, try looking for and clicking the “View User API Key” button to see if your previous API keys are displayed.

The user API keys are marked as Legacy, so I think they will be phased out in the future. For more details, please check the help page.


Yeah, you are right. Today I see this tab, but it’s new, yesterday it wasn’t there. Well, now I can manage the disappeared key as well.

1 Like