Action hangs in GPT builder

Starting this week I have been experiencing problems in GPT builder / editor:

  • GPT calls HTTP endpoint
  • GPT receives (a valid) API response
  • “Starting action” loader keeps spinning and reply is not getting generated
  • if I cancel generation or write another message on top then response immediately appears

The GPT works outside of GPT builder interface. I have tried working on different browsers and even another GPT, but same thing is happening.

Is anyone else experiencing this problem?

1 Like

I’m having the same problem… any fixes? I know my endpoints work, but the same GPT without any modification hangs intermittently

We’re having the exact some issues. Also within the GPT outside of the editor. Answers do not seem to get parsed. It seems to go wrong only the first time it tries to connect to an external api.
Screenshot 2024-03-14 at 13.57.35

I am having the same issue. Both inside and outside of the builder the GPT action hangs when making an API call.

I noticed it does not seem to be an issue if there aren’t any documents added to the knowledge lookup. When it does hang there is no reference to making a knowledge lookup though.

I’ve been experiencing this for 3 hours. Since I have no idea of API calls and OpenAPI Spec I thought my Schema were wrong.

But my API Schema, which i build with ActionsGPT is not working either, which worked a couple of days ago. Hopefully it’s a technical error, because I was considering to quit AI stuff and do my bachelor thesis in the oldschool analogous and post-medieval way :sob: :sob: :sob:

Same here. Making a direct https call works fine from the browser. Going through GPT does not. And if I ask another question, it responds immediately with cached values. The answer is incorrect, since it did not actually invoke the endpoint.

Yes, same here. I got a ton of 1 stars because of this issue.

Same thing here, not a single actions is working since thursday.

I have a similar issue. The test of an endpoint worked fine yesterday.
But when running the custom gpt the action runs endlessly.
The really strange thing is, that today even the test of an action does not work anymore.
Actions seem to be not stable and are under heavy construction.
Hope this will be fixed soon.

Is there anywhere we can look to see if there has been some progress made on this? I have 42 custom GPTs and they are all broken right now and I am losing my customer base.

I found out, that my action is working fine when I do not upload any documents as my knowledge base.
As soon as I upload files I can ask questions concerning the content of these files but my action hangs up and runs endlessly !

Now comes the strange part: It seems to depend on the documents !!
In my tests and I could upload 2 PDF files and my action still worked.
But after uploading a 1 MB JSON file the action did not work anymore.

Please guys from OpenAI fix this soon.

Thanks a lot in advance, Uwe

@ud_chat Did you resolve this? My GPT suddenly stopped invoking API end points, for no obvious reason. As you’ve already noted, it seems to be related to uploaded documents, in some obscure way. If I create a new GPT with the same API endpoints, it works fine.

1 Like

This should be every builder’s first step when they run into any kind of weird issue related to actions in their GPTs.

Basically, turn it off and on again.

GPTs can exist in some kind of weird limbo state where broken code/instructions are somehow cached. This usually, but not always, happens after a weird, broken call to an API endpoint occurs or the GPT is saved with a malformed schema.[^I haven’t had the time or inclination to dive deeply into trying to find a reproducible way to break a GPT in this manner, anyone has insights here it would be useful to collect them as reproducible examples can be fixed.]

The most reliable ways to remedy this in order of destructiveness,

  1. Delete the action and recreate it. If the schema is good, it’s as simple as cutting and pasting it.
  2. Delete the GPT and recreate it. Same as Number 1 with a bit more copying and pasting and possibly some file uploads.

Try Number 1 first a couple of times before resorting to Number 2.

Anecdotally, there are reports that increasing the version number of the OpenAPI schema can help nudge the GPT out of the state it’s stuck in.

Thanks for your advice. You’re onto something, I removed all my actions and re-added them, to no avail. But after having removed one of my ‘knowledge files’ (a pdf), suddenly the API endpoints started working again. Not any file, just this particular pdf. If I re-added the pdf, the API calls started ‘hanging’ endlessly again.

But, unfortunately, all is not well and good. When testing the API:s (from within the GPT) everything looks fine in debug printouts, data is coming through. But the GPT either claims no data is returned or (worse) keep hallucinating, i.e. fabricates data (even though real data is returned in the API response).

Hi all !

I’m still looking for an advice how to handle the problem that adding a specific file to the knowledge base (e.g. by uploading a PDF) leads to a hang up of an action.
If somebody could explain how actions depend on uploaded files.
The strange thing is, that ChatGPT recognizes that the user prompt needs to call an action but after starting to run the action it hangs endlessly.
After deleting the upload knowledge file, everthing works again fine.

Help would be very appreciated !

Hi @ud_chat ! Sorry, I have no answer, but can agree. I have this problem “all the time” and it’s very frustrating. I’ve tried all sorts of stuff, i.e. different data structures, file formats etc., but still - the ony way I’ve found to get the API:s working again is to remove the offending file. Sometimes the problem occurs after the second uploaded file, sometimes after the n:th file, I can not see any patterns.

1 Like

I’m glad I found this thread. I feel as if I have been going crazy over the last few weeks. I have had, and still having, the same problems mentioned here. The worst thing — no discernible patterns as @anders.elias said.

I’m experiencing the same bug.
Even in my case, if I delete one of the two uploaded files, the pending phenomenon disappears when I call the api. I’ve been looking for it for a few days, but it seems that this is the only solution.