A single Assistant API method call exceeds Rate limit? Need advice

Hi all,

I know there have already been a lot of similar questions, but I would still like to get an answer and advice…so:
I’m just playing around with the ASSISTANT API calls, as described in the docs:


So, I created an assistant, a thread, a message, started Run, and everything went as it should. But, when I tried to retrieve the Run object (in order to see status), as described here:

with plain Postman tool, I always get the following error

"last_error": {
    "code": "rate_limit_exceeded",
    "message": "Rate limit reached for gpt-3.5-turbo-1106 in organization xxxxxxxxx on requests per min (RPM):     Limit 3, Used 3, Requested 1. Please try again in 20s. Visit https://platform.openai.com/account/rate-limits to learn more. 
    You can increase your rate limit by adding a payment method to your account at https://platform.openai.com/account/billing."
  "model": "gpt-3.5-turbo-1106",

And no matter how much I pause between the two calls, I always get this one and the same error. I repeat, I use regular Postman for the API call. Can someone please explain why this is happening?

Further, since I am still studying the Assistant API, and that I am far from any production and commercial use, is there something like a free tier, let say “development mode”, which provides a little bigger Rate limit, OR do I need to pay extra to use the API during research/development also?

I recommend taking at look at the Rate limits - OpenAI API documentation if you haven’t already.

It seems that you’re running into the RPM (requests per minutes) limit, which in the free tier is only 3 requests.

If you put $5 into the API you’ll get a much higher rate limit, enough to play around a bunch.

Thanks for your reply.

What confuses me, is that calling just one Assistant API method has more than 3 requests in it. Can you explain what counts as one “request”? What exactly does he represent?

On the other hand, according to what you said,the only way to overcome this is to make an additional payment. Am I right?

1 Like

I don’t know why an assistant API call would count as more than one request, they haven’t been super transparent about how the assistants work so it’s hard to tell.

The only other possibility I can think of is that the gpt-3.5-turbo-1106 might not be permitted on free tier, but I am unable to check this since I’m in tier 4.

Making a payment is the only way to upgrade your usage tier though.
It’s a fairly small amount of money and it gives you access to GPT-4 as well.

1 Like

I’m running into the same issue. Were you able to find out what was going wrong?

Yeah…you need to pay for more API calls… :disappointed_relieved: