Getting "OpenAI's API rate limit reached." while I NEVER used the API before

I just registered to OpenAPI, generated an API key (new one) and use it in a piece of software that generate missing code documentation. I tried it on a single file and permanently get “OpenAI’s API rate limit reached.” I NEVER EVER used the API before.
Bot help is useless.
What did I do wrong? How can I proceed? How to contact human support? Here?
(I tried with a bad API key and get the message that the key does not exit. So my API key seems to be OK.)
Many thanks for your help.
Sorry for this probably stupid issue.
Best regards.

Hi and welcome to the Forum!

Which model are you trying to use? Are you in the free tier or have you pre-paid any credits into your account?

The “hello world” example I first try uses gpt-3.5-turbo.

Assuming you are under the free tier then, is it possible that your file exceeds the token limit?


The API is not free. OpenAI is no longer granting trial credits.

You’ll need to go to , choose settings->billing, add a payment method, and purchase prepaid credits in order to make API calls and pay for the actual data usage.

The error message about rate limits likely continues with “…check your plan and billing”.

Makes sense, I had not considered that. The only point I’ll add is that for lack of API credits, I get the following error. But perhaps the error message differs on a case by case basis.

    "error": {
        "message": "The model `gpt-3.5` does not exist or you do not have access to it.",
        "type": "invalid_request_error",
        "param": null,
        "code": "model_not_found"
The model `gpt-3.5` does not exist

The model “gpt-3.5” indeed does not exist - that’s not the correct text for the API parameter model. You’ll have to either use the stable alias gpt-3.5-turbo or the full model name such as gpt-3.5-turbo-0125 or gpt-3.5-turbo-0613.

argh. yes, I’m defeated. it’s been a long day… thanks!

Thank you all for patiently answering my basic question.
(It shows that human are still best to answer issues.)
There are a dozen packages that do what I’d like to try (automagically add documentation to code), they are all very similar, they all come with simple examples, but examples do not work because of the issue I mentioned. Always the same error message.
My usage (in my setting page) is of course a flat 0 for all activities/cost. If one of my test had gone through (and burned TPM), I would expect to at least see a little peak in my usage, no? But there is none, since no test has gone through.
I still read that the Free Tier (User must be in an allowed geography, and I am), Usage limit: $100/month. So my understating is that I (hope I) can freely test my package(s) with that $100/month limit. If a package is suitable for me, I’ll later buy the necessary usage for my needs. But before I pay, I must be certain that it works.
Currently, given this experience, I’m definitively not sure it would work better if I paid.

Despite my earlier error, I can confirm that this is no longer possible based on a personal test account I put in place. It does indeed still say free tier, but we can assume at this point that free credits are discontinued. Sorry!

Here’s the link where you can see your current account balance in API credits that can be used for paying for API services, add a payment card, and then purchase those credits.

Free Tier? not familiar with it… why would Open AI API be free? heh. just load some dollars in ($5? it will go a long way with 3.5 turbo 1106 or whatever the current model is) and try it out… as soon as I saw your issue I knew it was probably related to not having loaded in any credits. It’s super easy, and it will go a long way, just add some credit to your account and move forward. Once you load credits in you can see your Usage and you will see just how far your testing can go with 3.5, 4 is about 20x more expensive, the credits get used much more quickly, but 4 is also far superior to 3.5… my suggestion is to test POC with 3.5 and when you’re ready to really rev the engine, then switch to 4. I have developed a product over MONTHS with repeated 3.5 calls and I have probably spent $35-40 in API fees… pushes Staples that was easy! button

I was having same issue even after paid subscription.

  1. Recharge your account with at least 20$.
  2. Generate new API key.
    That’s all , you will be now receving even GPT-4 and DALLE-3 models.