Webpage of Usage Dashboard Goes Blank


I’m using the 3.5-turbo API these days and everything is fine. However, I cannot see the usage dashboard OpenAI Platform from several days ago.

Every time I visit this webpage, it just shows the text and the dashboard with gray blocks (without the real-time data) for several seconds and then the page goes blank. I’ve tried on Chrome and Safari on MacOS, and the Chrome on iOS, and cleaning cache of the browser, but the problem is not solved.

If I try with other accounts, this problem does not appear, so I guess the problem is with my account rather than the network and browser.

Do you know how to solve it? Thanks for your suggestions!


BTW, other tags such as Rate-limits and Settings are fine; but if I switch from them to the Usage tag and the webpage goes blank, then even if I click the backward arrow of the browser, the pages of Rate-limits or Settings will always be blank, unless I reload the webpage manually.

As suggested by @PaulBellow , here I provide the settings of my case (all with the same network, and the error message is just the same as @grandell1234 provided in the 46th post below):

  • MacOS, 2nd account registered with email, Chrome/Safari, September (default), having usage records → crashed
  • iOS, 2nd account registered with email, Chrome, September (default), having usage records → crashed
  • MacOS, 1st account with Google, Chrome/Safari, September (default), no usage records → normal
  • MacOS, 2nd account registered with email, Chrome/Safari, August, no usage records → normal

grandell1234’s case:

  • OS: macOS M1, Browser: Brave, Search Engine: Start Page, Number of Accounts: 1. → crashed

Has your OpenAI account received any bans?

I never received this kind of message, and the API still works well.

I have the same problem. API works, but after accessing the usage tab the page goes blank.

I have the same problem, once I go into the usage section it loads for half a second, then it turns into a blank white page.

I get this error in the console and a few more

from origin ‘https://platform.openai.com’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource

1 Like

The CORS policy error from Azure has happened to a few since the display was updated recently to show usage-by-model in color.

You can hold down shift and press the browser’s reload button, (or ctrl-f5) to force a reload of all web page code. If that doesn’t help, then OpenAI likely has some problems with the way they set up the usage assets on the backend site.


That makes sense! Thanks for answering! Unfortunately the ctrl+f5 solution doesn’t work for me and still loads the blank page. It sounds like the latter issue.

1 Like

thank you all for the repsonses. I can not solve it with ctrl+f5/+R, same with monjaseunja.

Seems that what we can do is wait …

1 Like

Same here too… ctrl+f5 solution doesn’t work. A JavaScript error visible on browser’s console panel.

same here


I have the same problem since last week. Is there any other way to see $ usage?

You can see how much credit you have left in the ‘Billing’ tab. But no other way that I know of to track spending.


Hi. I’m watching and practicing with a tutorial video project about use AI.
In the video, its said about a free trial credit and it would be more than enough to use on this mini project.
I did check my main google account, which I only use for chatGPT3.5, but the credits did expire a time ago.
A friend recommends create a new account, so I did use a secondary google acc I have.
The issue is, I cant see the Usage page on this acc. The website pre-load and then,

become blank.
I did check on my main acc and there I can see normaly my Usage, so I think its not a internet issue or a browser issue or a extension which could been blocking something.

But I dont know what to do and see my Usage on this second accont, just to even know if there is a trial credit on it.
My Usage scren on my main acc:

The preload page before become a blank page (less than 1sec)

Then, the blank page 100% “loaded”

Welcome to the community!

Keep in mind that creating alternate accounts for the free trial usage is against the T.O.S.
There have been page errors before so I would recommend reaching out to a staff member for assistance.

Hi grandell, thx for the repply.

I did register at first only to use chatGPT. I never knew about this trial credits or even its had a expiration time. So I never could really use the trial (on that time, I only knew about chatGPT)

The problem was already reported here: Webpage of Usage Dashboard Goes Blank - API - OpenAI Developer Forum, but I thought about reopening it since that is labeled as solved, but the problem is still very much there to me, and shift+f5 won’t work, same as clearing the cache.