Unable to use gpt-4-32k model

Hi there,

GPT-4-32k access was enabled on our account yesterday night and I can see the model in the playground as well. However, both on the playground and via curl/insomnia I can’t seem to use the gpt-4-32k model. I get an error saying ‘engine not found’. For context, this is the first and only gpt-4 model that’s been made available to us.

I saw some forum posts about similar instances and one of them suggested creating a new key - but that has not worked for me.

Please advice on the steps to resolve this!


Hi and welcome to the developer forum!

Can you posta screen shot of your model list in the playground when you click show more models? it should look like this


Thanks for the swift response! Here’s the list of models!

I just tried and gpt 4 32k 0314 seems to work for me but not gpt 4 32k and gpt 4 32k 0613

can you post a code snippet of the API call you are making? make it the one that fails, I’m looking for possible syntax issues.


I don’t think it’s a syntax issue because even the playground call fails! see this screenshot:

The cURL for the same request:

curl https://api.openai.com/v1/chat/completions \
  -H "Content-Type: application/json" \
  -H "Authorization: Bearer $OPENAI_API_KEY" \
  -d '{
  "model": "gpt-4-32k",
  "messages": [
      "role": "user",
      "content": "Hi"
  "temperature": 1,
  "max_tokens": 256,
  "top_p": 1,
  "frequency_penalty": 0,
  "presence_penalty": 0

So I think it’s an access issue and not a syntax issue.

1 Like

Agreed, it does look unusual. Unfortunately, this leaves the realm of technical issue and becomes account based, i.e. something on your account is setup incorrectly or was enabled by accident, 32K access is rare to be granted, so I’m not sure of the circumstances, but if you did not request it, I imagine it’s a mistake. either way, you need to reach out to the support side of things over at help.openai.com and user the bot in the lower right corner to create an entry in the system with your issue. I wish you well!

1 Like

Thanks so much for the help! Really appreciate it :slight_smile:

1 Like