Seeing "detected unusual activity from your system" error message when testing local plugin

I’m developing a plugin locally and am seeing this issue:

Our systems have detected unusual activity from your system. Please try again later.

Has anyone else run into this issue? I was seeing this issue yesterday as well. Locally testing and running the plugin was working ~ a week ago without me changing any of the code I’m running.

The code I’m testing is open sourced here @ my github dswilson4 (handle) messari-plugin (repo name)

I’m seeing successful requests made and received on the plugin side:


While I can not confirm any of your ideas I also can not say they are wrong.

I too have seen my plugins being developed using localhost work one day, no code changes, then fail the next day. Granted I am also starting up different plugins being developed using localhost in between so that might have some effect.

One thing that seems to work is to try the failing plugin first thing the next day (thinking a cache is cleared).
The other thing I am trying is to change the version in the OpenAPI specification file with any change in any of the files, even a single character or byte change, or adding debug statements.

So while I can not solve these problems I can confirm that you are not going crazy.

I suspect that OpenAI is tightening up the checks for plugins being developed and the documentation is not being updated. I would welcome emails a few times a day at this point if such changes are occurring. One user here that I did converse with noted that his plugin was rejected because a name was not 19 characters or less but in checking the documentation it noted it could be 20.

I’m having the same issue too. And it’s happening with all the GPT-4 models. The GPT-3.5 ones are working fine. This is happening regardless of the extension I use with GPT-4 in my browser.

I can confirm

Here the same!
Acutally I didnt do anything about development except from asking questions?
my emial address is
and paid for the subscription, never did anything integrated with plugins at anywhere on this world
but it just showed there is detected unusual activity from my system
What’s wrong with my account? I just want to figure it out

Me too. - I don’t think I am doing anything fancy. I am a doctor, using it to help me write a departmental rota. I am just learning how to use it. I noted a problem in a calculation and said " no person X has had 2 weeks holiday, not 0 holiday (calculating holiday had previously worked) and it did this. Like an employee going off in a strop because it did something wrong (anthropomorphising)

This is an absolute horseshit way to treat paying customers.

1 Like

Yes, I am having this problem at the moment as well.

Same issue here. Not doing anything unusual. Just trying to use my paid account, and getting stymied. Is the system just down? If so, are there plans in place to refund for a product not being provided?


Yes it is. It doesn’t appear able to follow many multi-item commands and then limits the number of commands. Anyone now how long later is later - or how to fix this please?

Same issues here. At least return an error that clearly illustrates what the problem might be.

1 Like

same situation here

Same here, on the web, and in the web view of the MacGPT app. Could MacGPT be common here, between us?

lol is GPT-4 really “victim blaming” us??


I think there is a global outage. I think wait and drink tea is the only thing I can do.

Same error here, what is wrong with GPT 4?

Same thing here. Just creating a content template in the web browser with Chat GPT4

1 Like

I first thought that it must be because I was using Brave browser but alas this does not seem to be the issue.

Ah well, back in the real world, my house is a mess, maybe I better go and do the laundry!

Totally agree. I was doing nothing suspicious and cannot use my paid plan, so I should have 24-hour access. I am loosing time right now.