openai.error.InvalidRequestError: The model `gpt-4` does not exist or you do not have access to it

I’m a complete newbie to openai so please bear with me, and I’m also hoping this is the right place to ask. I’m trying to follow this youtube video to get open interpreter working:
[Open Interpreter :desktop_computer: ChatGPT Code Interpreter You Can Run LOCALLY! - YouTube]
I’m running into a brick wall when it comes to the api key. I can generate a key but the terminal throws this error:

’ openai.error.InvalidRequestError: The model gpt-4 does not exist or you do not have access to it.’

I’ve been searching on google but can’t find a solution to this. I also tried to upgrade my openai account but that came back asking for £20/month which doesn’t sound right, especially after reading on google users need to pay just £1.
thanks for any pointers

1 Like

It is here that you need to add a payment plan and purchase credits to use the pay-per-use API: Billing Overview

After making a successful payment (minimum $5) the gpt-4 model and higher rate limits should be enabled.

Also don’t do what that sponsored video says. He talks about the AI running code: “here we can see it shows what is on my desktop” - sure, and now get it to do some hallucinated regedit. AI needs to run python in a sandbox for safety.


Hey Champ,
And welcome to the developer community forum, you’re definitely in the right place if you want to learn! (The forum has a great search function btw, you’ll find many solutions to common problems here)

The error message indicates that the model gpt-4 does not exist or you do not have access to it. Please ensure that you have the correct access permissions and that the model name is spelled correctly.

I’ll suggest you follow the advice by, @_j, that’s usually the quickest way of solving this, we’re not able to help you gain access.

You can see which models you have access to over in the playground, under the “model” selection tab in the settings:

I hope that helps!


thankyou @regular that has solved it for me. I purchased a small credit at the link you gave and now open interpreter is working and no longer spitting back the api key.


Hello, how can I convert the natural language processing model from bin to gguf