oAuth not working anymore with plugins

Hello everyone,

Is there any change with Plugins oauth?

Before one week everything was working perfectly not it not working anymore… My server still returning access tokens without issue but login not passing as before, maybe chat gpt expecting other way of response or something changed?



Have you seen this post? Might be applicable.


Can you be more specific about what’s not working? I’m not sure what ‘login not passing as before’ means.

If there are errors when ChatGPT tries to make plugin requests, then it’s possible the access token has expired and you can use refresh tokens to fix this.

I marked solution above… All is fine now. Documentation missing this state parameter it wasn’t required before.


oAuth is again broken I getting same error but I sending state param correcly, anyone know what is now introduced?

Agree with above, oauth is broken.

I have an app in the store that was published using the state parameter a couple of weeks ago and was working until yesterday. Today after the redirect back to chatgpt get the following error:

“Couldn’t log in with plugin.”

My Plugin Tutory is experiencing similar issues and I have the state parameter included. I tried all the different ways of doing it and nothing seemed to work. I notice some of the bigger plugins are also not working that have OAuth so this may be a wider issue.

I confirm that it’s completely broken since a few hours now.
In case that could help, here’s the server error we get when the login flow eventually redirects the user to ChatGPT:

1 Like

Seconded, we’re returning the state parameter and still erroring out. Console is completely useless in debugging.


I confirm that I am dealing with the same issue

bump @logankilpatrick can we escalate this ?



Can I ask if you are using PluginLab?

I can confirm, getting same error too - int object has no attribute total.

I’m not using PluginLab, using plain OAuth and self hosting the plugin.

Hi and welcome to the developer forum!

Have you created a report in the Bugs category?

No, I rolled my own authentication.

1 Like

Noteable developer here, our plugin uses OAuth. What I see from our server side logs is that ChatGPT goes through step one of the OAuth flow, 302 redirect to our authorization endpoint (which we redirect on to auth0), but we never receive step two of the OAuth flow, the POST to retrieve the JWT.

In the ChatGPT UI, as a user I see the toast message about not installing the plugin. In console/network tab logs, I see that a GET to https://chat.openai.com/backend-api/aip/p/plugin-179013de-6465-4e36-8bbd-49e36767e91c/user-settings/oauth/callback had a 500 with the body “detail”: “Error forwarding auth: {"message":"‘int’ object has no attribute ‘total’"}”.

I can confirm we are passing the state parameter through. From my perspective, it looks like an error on the ChatGPT side in between steps one and two of OAuth, after the user has been redirected back to ChatGPT with the one-time code, but before ChatGPT does the POST to retrieve the JWT.


I am experiencing the same issue. Confirmed state is being passed to redirect uri properly.

Disregard it is working now. Strange I was just getting that error though

I’m now having the same issue with a plugin that worked fine about a month ago… anyone have a stable fix?