Can't get ChatGPT to recognize plugin

I for some reason am having a hard time getting a plugin to work. I have tried so many different approaches, it can’t be this hard!

I am behind Cloudflare, which could be the problem, but I can not prove it, I don’t even see ChatGPT hitting Cloudflare. But regardless, I have a rule set up to skip the json and yaml files.

If I do this all locally, it works as expected, just not on the live server.

I have tried Coldfusion: Can’t get it to find the plugin

I have built a separate API in Flask, which I could get working locally, but not working live.

I’m running out of things to test. I am dumping out the request to a json on the server, and it appears ChatGPT never even hits the request or it would dump out something.

Not much in the way of errors.

  1. {detail: “Error getting plugin: {“message”:“Plugin not found”}”}

  2. detail: “Error getting plugin: {"message":"Plugin not found"}”

Any ideas that I might be missing?

I have to say … your plugin works fine on my machine … :rofl:

Thank you for checking that, I can get to it now as well. That got me to the next step of confirming that Cloudflare does have something to do with it. I am going to head over to Cloudflare and see if they can help me get through the firewall.

I’ll post back when I get a resolution in case .

Got it working. I just allowed the openAi URL’s through the firewall in the custom rules. Thanks to anyone that checked that for me.

Verified Working