Is text-embedding-ada-002 down?

I am trying to embedded some text and I got no response, 1 hour ago was working fine
Does anyone experiencing the same problem?

DEBUG:openai:message=‘Request to OpenAI API’ method=post path=
DEBUG:openai:api_version=None data=‘{“input”: [“This is for demonstration.”], “model”: “text-embedding-ada-002”, “encoding_format”: “base64”}’ message=‘Post details’

from langchain.embeddings import OpenAIEmbeddings

emb_model = OpenAIEmbeddings()
input_text = "This is for demonstration."
outcome = emb_model.embed_query(input_text)



Switched my internet connection to the cel phone and it seems to work, something related to my connection

1 Like

Please mark your post as the solution in case anyone else encounters the same issue today (it even further in the future) it may help them.

Incidentally, yesterday I couldn’t connect to ChatGPT from my home Internet but it worked fine when I hopped on my university VPN, I figured it was a transitory CloudFlare thing so I didn’t post about it.

But, yeah, please mark your topic as solved to help others.

I think it is unstable now, worked for the simple text, but if I try to send a larger text from a PDF it does not work. is all green at the moment.

I’d consider reporting it through if you’re certain there’s nothing on your end causing it.

Try to find where exactly things break.

  • Is it just text from that PDF or all PDFs?
  • Is it only certain sizes of text (I’m assuming you’re not exceeding the token limit)?


1 Like

I looked at before posting here.

The larger PDF problem was an error on my side. Now everything is working.

Probably was some instability and I did a code change at the same time. Them when the API was back my code was broken so was kind of weird.

Thanks for your help

1 Like

No worries!

I’m just glad you’re back up and running.