I can't upgrade to ChatGPT Plus

For some reason, as I am trying to upgrade to chatgpt Plus, I keep getting stuck on the human verification puzzle, which looks as if it wasn’t a button at all and won’t click through to the actual puzzle.


Hi there, have you solved such a problem yet, cause I confronted with the same problem?

1 Like

Hi, I am facing the same issue. I cannot click on the button. Any solutions in sight?

Edit: I found a solution, in the top right of the page there is an X. Click on it and then you can click on Begin puzzle.


Same… Tried with Chrome, Edge and Safari as well.

Same… I tried Chrome, Edge and Safari as well. And incognito mode. Any solution to this?

1 Like

I got through. By clicking “Esc” one time


This trick of clicking “ESC” helped me find a workaround for a bug in their human verification API, enabling renewal. Thanks

1 Like

Worked for me too!
The solution is to press the X button in the top right corner of the page only once, then “Begin puzzle” button will be activated.

Had the same problem and solved it the same way, clicking once on the cross at the top right and then the puzzle button. For future reference, I’m on Linux Mint 21.3, both Firefox and Brave display the same behaviour.

No luck upgrading, pressing esc did not work
, running chrome on Ubuntu

Thank you! I have tried your solution and it worked for me.