HPPT: 403 error. Seek for guidance

Hi folks, I was trying to do a first fine tune test with a sample .jsonl training data file shared by Dave Shapiro (thanks!). I was executing the fine_tunes.create command and got an error code reads:

e[91mError:e[0m The OpenAI API can only be accessed over HTTPS. You should access https://api.openai.com rather than the current URL. (HTTP status code: 403)

I did searched online and also asked ChatGPT how to resolve the issue. It seemed that my system is blocking https traffic to the api endpoint. But nowhere I cound find to “unblock” the connection. I also searched the FAQ and help center, it does not have this 403 error code recoreded.

Had anyone run into the same problem before? How could I fix the issue. Thank you so much!

See Cloudflare Errors:


Thanks! I read it and understood the issue, but still don’t know how to fix it. It appears to be an error without Cloudflare branding in the error code, so should I contact OpenAI or do something with my own security settings?

Maybe double check the URL of your API you are using?

Did you forget the https ?

Resloved, here’s the report, although I’m still confused why:

The command and endpoint url are all correct. The fine tune command I used earlier was “openai api fine_tunes.create -t /questions.jsonl --model ada --batch_size 64”, and it gives the 403 error.

I modify the command to “openai api fine_tunes.create -t “questions.jsonl” --model ada --batch_size 64”, only differencce is the traning set file filed changed from / to " ", and the comamnd successfully executed…

I’m beginner and I get too an 403 https error code ?
May be you cans help me?
Best regards.

1 Like

I am facing the same issue, I have wordpress plugin so not able to change code, can I fix it?

I had the same issue for a few hours today. Then the error disappeared intermittently for new requests and later on the error were all gone. I sent the same request every time so it wasn’t anything i did

I suspect error 403 might have to do with server overload.