Fine-Tune endpoint not working


So, I’ve created a fine-tune with Curie, but when I try to call the endpoint with the id or the “fine_tuned_model” attribute, I keep getting an “invalid request error”. The documentation says we should call our fine-tunes just like any other engine, but it isn’t working. I use Ruby, and I’ve built a wrapper myself, so I haven’t tried calling it using python. Curiously, the completion endpoint/ POST request works just fine with cURL.

Here’s the endpoint I’m trying to reach:


If it works fine with curl then it’s down to your Ruby implementation. Likely you need to swap engine for model in your parameters.


Hi @boris I tried ‘ model name here/completions’ to no avail (and infinite combinations therein). I see in the python implementation the parameter is called “model”, but what is it called when it’s just called with the URL like this? Also, my mistake, I got it working with the openai CLI app, not curl.

1 Like

Hey @m-a.schenk ,

Thanks for the help! I figured it out. It turns out my model needed to be in the request body and not in the URL. It was a big facepalm moment when I figured it out lol. Good to go!

Thanks again.