Error "Incorrect API key provided" when using DALL·E on the website

I’m experiencing the same problem as well. Thanks for the hard work OpenAI team. Looking forward to the fix.


The issue is still there. We are looking forward to the fix. Thanks!

1 Like

Same here. Waiting for a final fix.

1 Like

Having same issue, also waiting for the fix

finally it has worked, have done nothing, just reloaded the page C^R

Issue is still there for me. Brand new key, copy pasted into the curl command, same old error message.

same issue. I am getting same error

still getting the issue

I found this link and generated a new secret key, then closed and opened my browser and now it’s working

Same error, I tried four times and the error came four times.

The last time, the error came after the “sample gallery” dissappeared and my image was supposedly generating. Then the error appeared.

I decided to go to History and took a while to refresh the history like 2 minutes. At the end, four images of that last failed request were there.

Same issue, just trying it for the first time. Doesn’t work.

Seems like the issue is back… the api key works only for one single call and then it changes :frowning:

Today I was able to use my API key in the morning, without issue. I generated a new API key, removing the original and since then I’ve not been able to use the service - I receive the incorrect api key provided message.

having the same issue, after deploying to netlify, did any one find the solution to the problem. yet

I’m trying use API key in a code node js, and return me the same error, some one else can solve it ?

openai.error.AuthenticationError: Incorrect API key provided: <sk-tz1o*****************************************AbL>. You can find your API key at OpenAI API.

I meet the error with python API and command line:
$ openai api completions.create -m text-davinci-003 -p “Say this is a test” -t 0 -M 7 --stream

anybody can help me how to fix,I have try the ways of Help Center,but why AuthenticationError,cause I am free user?

Facing the same authentication error even after using the right key. Looking for fix.

Most likely upload your key to github, don’t do this, openai will simply reset your key, you need to create a new one

Summary created by AI.

The error “Incorrect API key provided” while using DALL·E has been reported by several users, as discussed in the thread. UweKeim stated encountering this issue when attempting to submit a phrase, even though they were not using an API key. After logging off and back in, the problem seemed to be resolved. PaulBellow suggested refreshing the browser, while Silva recommended resetting cookies, reloading the browser, and generating a new password on the OpenAI site.

However, some users encountered persistent problems. OldKingSwole and iovarares said that logging in and refreshing didn’t work. lindapaiste found that their problem was resolved through a process that included logging out, emptying cache, and hard reloading, but expressed annoyance at having used up result credits in the process. goreallaffiliates, chrisbeach, AlexEcchi, and bob108891 also reported experiencing similar issues.

josephfrusetta added to the conversation by saying they were only encountering this problem when using DALL·E and despite their attempts to use different browsers, the issue remained. The same user reported that the problem resolved itself after approximately two hours.

Finally, ted-at-openai, representing OpenAI, acknowledged the problem, confirming it was on their end and assured the community that they were working on a fix. t.ahmadsyamil expressed their appreciation for the OpenAI team’s work towards the problem’s resolution.

Summarized with AI on Nov 24 2023
AI used: gpt-4-32k