Don't see a request sent to the localhost server

as the image above shows, the interpretation of the API seems to be working fine and generating the right request body, but I don’t see a request sent to the localhost server.

Welcome to the forum.

Did you use Open plugin devtools and check the Prompt for ChatGPT to make sure it looks correct?

For this real example

// Plugin to pass OpenAPI reqeust as text/plain.
namespace String_arugment_test {

// pass text
type passText = () => any;

} // namespace String_arugment_test

notice type passText = () which creates the same problem you note,

however with this other plugin that works (ref)

// Compile SWI-Prolog code and return results, success or errors.
namespace SWI_Prolog_REPL {

// Compile SWI-Prolog code
type compileCode = (_: {
// SWI-Prolog code to compile
code: string,
}) => any;

} // namespace SWI_Prolog_REPL

there is a property for code.

To access the Open plugin devtools

  1. Open ChatGPT
  2. In the lower left click your user id to expand the panel.
  3. Click settings
  4. Enable Open plugin devtools


Please do not ask me how to modify the OpenAPI specification to correct the problem, I have been stuck on that one for a day now just trying see if text/plain can be passed with POST, thus the name of the plugin with the problem String_arugment_test


Many thanks! We’ve managed to resolve the issue! This was attributed to some irregularities within our API documentation. Initially, we offered parameters in a choice of ‘string’ or ‘number’ formats for ChatGPT to select, but as it happens, it only accommodates one format. Upon changing our approach and exclusively employing ‘string’, the issue has been successfully addressed!

1 Like