Dall-e says "You are not allowed to sample from this model"

My usage limits show that I can query dall-e-2, but when querying from the playground or via curl I just get “You are not allowed to sample from this model”

Welcome to the forum.

DALLE3 is not available via API or Labs yet…

Right, which is why I’m querying 2, as I mentioned in my original post

Oops. Sorry about the mis-read.

Can you show your cURL command?

You can’t query DALLE2 from Playground - did you mean Labs?

They just put dall-e-2 in the playground under “completions”.

$0.02 to see if it works.

1 Like

Interesting. Just refreshed and found it…

I wonder if it’s a mistake as it has the normal text completion settings. Doesn’t seem to do anything.

Hi, I’m getting this error “You are not allowed to sample from this model” too. I tried ‘dall-e-2’ and ‘dall-e-3’. I am also using curl. Documentation here specifically gives me instructions on how to use it with API.

I resolved the issue. I was using the wrong API URL. Make sure you are using the Dalle api endpoint instead of the chatgpt api endpoint.

1 Like

Thanks for coming back to follow-up. Hope you stick around the community.