Custom GPTs - Send text to endpoint - asks for confirmation every time

I created a custom gpt with an action to send text to an api endpoint.

Like when you type “send test123” it will send test123 to my custom endpoint.
This works fine it’s just asks me every time to confirm before it sends the data
“Custom GPT wants to share this info with…”

Is there a schema parameter to allow the user to “confirm forever” or at least “confirm for the current chat”?

1 Like


It’s the ‘consequential’ flag you are looking for.

You can resolve your issue by setting the flag to ‘false’.

If the x-openai-isConsequential field is false, we show the “always allow button”.