API permissions asked every time for GPT action

Hi, I’ve created a GPT for latest news.
It uses my endpoint to grab the latest. However, I get “Allow this?” message every time its called.

I see that once its my ‘personal’ chatGPT, I can go to Privacy and click on “Always Allow”. But its a poor user experience.

How can I make it so that it doesn’t ask this question more than once to the end user?

You can adjust the consequential flag

See here

If the x-openai-isConsequential field is false , we show the "always allow button

1 Like

Hi there the link you’ve added is unfortunately not working anymore and I am unable to fix the problem the initial post was about. Would you be able to advise me how to do it

here is the updated link for the consequential flag behavior:

https://platform.openai.com/docs/actions/getting-started#:~:text=Consequential%20flag&text=If%20the%20x-openai-isConsequential,users%20more%20control%20over%20actions

found in ChatGPT - Actions - Getting Started