Could not parse manifest as JSON: Expecting value: line 1 column 1 (char 0)

Keep getting this error. Here’s my JSON. Can someone help?

  "schema_version": "v1",
  "name_for_human": "Movies API (no auth)",
  "name_for_model": "movies",
  "description_for_human": "API for retrieving relevant movies or series and their poster image URLs from the streaming service Tubi.",
  "description_for_model": "API for retrieving relevant movies or series and their poster image URLs from the streaming service Tubi.",
  "auth": {
    "type": "none"
  "api": {
    "type": "openapi",
    "url": "",
    "is_user_authenticated": false
  "logo_url": "",
  "contact_email": "",
  "legal_info_url": ""

1 Like

Counting the commas and curly braces - they seem to be ok.

Another cause could be a hidden character at the beginning of the file, a common example is the BOM (byte order mark), which can be added by some editors.

Same Error from my side too. What is the solution?

I guess this error is due to ngrok, I have tried localhost, then using another production server. All are not giving any error.
So there is bug with ngrok

I ran the code above thorough a JSON validator and it looks fine. My guess there might be the response from server delivering the file is missing the correct Content-Type header or similar. Another though is to check that OpenAI reaches your file at all and is not fetching a 404 not found page.

Same here, my json is also correct, using the ngrok website externally to check if the ai-plugin.json is visible or not. It was visible but this error is still occuring.

Same here. I’ve checked my JSON through a validator. Called my manifest endpoint (/.well-known/ai-plugin.json) in a browser and it it came through.

same. works when i use localhost but not ngrox

same, so frustrating… fix this SHIT

If you have pasted that JSON from a notepad , it removes those hidden characters that originally created the problem.

Save that file as a txt. Open in Do you see something near the head of the file, that’s where the problem is.

I don’t think this is a server side error.

that’s not the issue. it’s perfectly formatted using json LSP

the json is formatted thats fine.

But the file in which you have it, is that fine? does it contain BOM like others have mentioned?

yeah that’s not it david. there is nobomb in my json file

If you’re using ngrok you can inspect the requests and responses and see what is happening.

When you run ngrok it should tell you how to access the web interface.

Doukbke check that you can browse to the file as well.

Saw a similar thread on this forum.

You might also be facing a browser problem. Any chance you are using the brave browser?

I have the same issue. Could it be that when OpenAI fetches the ai-plugin.json file through ngrok, the ngrok browser warning site is shown to ChatGPT instead of the manifest file? I think this would only be fixable if OpenAI adds the ‘ngrok-skip-browser-warning’ Header with any value in the call.

Related on StackOverflow: questions/73017353/how-to-bypass-ngrok-browser-warning (I can’t post links)


I think if you create an ngrok account and then do:

ngrok config add-authtoken XXXX

You can browse without any issues?

Use the dev tools, inspect the packet and see what the request/response is.

I had a similar error when calling openai finetune API with curl. A work around I find is to use postman to call the same API and it worked.

Yes this was it for me. Had to buy an $10/month account and regen ngrok url.