Code execution Python packages

I reactivated my plus account yesterday and I cannot find advanced data analysis button anymore.

I think it is now enabled by default along with Bing search. In notice also the switch for GPT-4 and 3.5 is on the left and no drop down list appears.

Shortly: it refuse to use any other python package except those that are already installed.

Also for customized GPT, no way to get for example stock quote using yfinance and some basic stats.
It fails downloading quotes in every other way (ie web scraping) … I think I get “error analysis”.

I did it in the very first days myGPT was publicly released, using a friend account, and he did the job smoothly.

At that time I think there still was the code interpreter/ advanced data analysis toggle.

So I don’t know if this is the intended behavior or if it is a bug.

1 Like

Welcome to the forum.

All features are just in one chat now, you just have to ask for it.

You cannot install new python packages into the sandbox anymore.

The OpenAI web bot respects robots.txt, so maybe you’re trying to scrape a site that doesn’t want to be scraped?

Thanks for your reply!
I was thinking it was just a matter of sandbox privileges but it is not clearly stated, at least I have not seen any documentation about that.

I asked for stock quotes analytics.
It tried to install yfinance, then it tried to scrape yahoo finance, then it proposed to me something else for about 2 hours but unsuccessful


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.