Chat GPT Desktop App for Intel Macs?

The new ChatGPT desktop app only works in Silicon macs. Does anyone know if there are plans to release a version for Intel macs? My wife and I have 2019 Macbooks that work perfectly well and we’re not planning to upgrade anytime soon.

18 Likes

I’m the same. In 2019, I bought a best configuration of Intel IMac, and there’s no need for me to replace it. If it won’t be able to use the desktop version of ChatGPT, I would be very disappointed.

15 Likes

In the same boat as many of you since I have an Intel Mac. With the “official” download link that was found, I was able to analyze all the target executables in the package. I was looking for any custom or third party libraries specific to the ARM instruction set (M chip), but each library was also compatible with x86_64 (Intel).

Libraries Used:

  • Standard Libraries:
    • /System/Library/Frameworks/Foundation.framework
    • /System/Library/Frameworks/AppKit.framework
    • /System/Library/Frameworks/CoreFoundation.framework
    • /System/Library/Frameworks/CoreGraphics.framework
    • Various other system frameworks and Swift libraries
  • Third-Party Libraries:
    • @rpath/Sparkle.framework (for software updates)
    • @rpath/Lottie.framework (for animations)

I could be wrong but given the compatibility of the libraries, it should be feasible for OpenAI to release a version of the app for Intel Macs.

10 Likes

In the same boat unfortunately :confused:

I’d upgrade to an Apple Silicon but my bank account already getting beat up by ChatGPT Plus subscription charges, lol.

6 Likes

Same. I own a 2019 iMac and don’t plan to update in the next two years.

12 Likes

Just want to add my vote to OpenAI making a version for Intel-based Macs. Certainly not upgrading a perfectly good machine for this, but as a Plus user, I’d be sorely disappointed if those of us not using the newest Mac end up out in the cold.

13 Likes

yep, I’m in too, it will be great

3 Likes

I have an M1 Max pro but the app will not install.
I get warning ’ *You can’t use this version of the application “ChatGPT.app” with this version of macOS
I’m on OS Ventura, it’s saying I must upgrade

3 Likes

It is not coming to intel as there are current and future features that require Apple Silicon.

1 Like