Can Not Add Files To Vector Store

Hello!

I am trying to utilize the Assistants API to retrieve data from files, and I am having issues with using the vector store.

I have tried uploading files both via the API and via https://platform.openai.com/assistants or /storage, and both methods leave me having the same problem.

I am trying to upload a txt file that is 153Kb. For the sake of the example I am going to use the web page as it’s more visual as to what’s going on. When actually selecting the file to load it, appears to be fine.

But upon hitting the attach button and the page updating, it shows that the upload failed.

It then becomes impossible to delete the file from the vector store and I have to delete the entire thing to clear the file out.

Am I doing something funny here that is causing this issue? Is this a known problem?

Let me know, thank you.

2 Likes

On top of this, assigning files to a vector store is also buggy I guess. Files successfully reflected as uploaded are also not mapped to any Vector Store.

try changing name of the file. Instead of 500leads, try leads500 or leadfivehundred. I saw a post where it was mentioned that if your file name starts with capitol letter, it will throw an error.

Very weird situation.

I went ahead and tried that solution and unfortunately even with just the name “leads” I’m getting the same problem. What a mystery!

It does appear to be buggy in more ways then one.

I’m also seeing that if I switch between vector stores where the file upload has failed in the Storage tab on platform.openai.com that the entire page freezes and I have to force it to close.

As mentioned trying to delete the file results in a spinning wheel forever. I just checked the developer console and it looks like it might be an issue with updating the file? Let me try this in a different browser…

I am too facing the same issue; attaching files, uploading files using browser or API fails without any errors.
Are there any logs that can be checked; the API response just says error.

Strange!

I reached out to their support chat and provided details on 5/7, I have yet to hear anything back yet. I hope this is on their radar, as it makes Assistants unusable for me until it gets fixed.

1 Like