AutoGen facing the "No API KEY provided"

I am trying to create an playground environment using AutoGen for LLM practice.
However, I run into the following issue:

efault_api_key
    raise openai.error.AuthenticationError(
openai.error.AuthenticationError: No API key provided. You can set your API key in code using 'openai.api_key = <API-KEY>', or you can set the environment variable OPENAI_API_KEY=<API-KEY>). If your API key is stored in a file, you can point the openai module at it with 'openai.api_key_path = <PATH>'. You can generate API keys in the OpenAI web interface. See https://platform.openai.com/account/api-keys for details.

My code is as follows:

config_list = [
    {
        'model': 'gpt-3.5-turbo-16k',
        'api-key': '[my api key]'
    }
]

What could be an issue here? I’ve already tried to use the solutions from github related issue (can’t post a link, issue #184)
Autogen’s user proxy agent begins execution though, it’s the asisstant that causes an error.

Did you find a solution to this? I don’t want to duplicate information by also storing the API key in an env (although this does work)

It was an issue with naming the OAI_CONFIG_LIST FILE, in my case it was necessary to add a .json extention to it if I recall correctly. Just make sure that AutoGen gets to process .json object containing the API key.