Assistant run remains queued for a long time - II

Unfortunately, I’m still getting this issue.

2 Likes

It doesn’t seem to be resolved - I am still getting the same issue.

1 Like

The first two replies to this topic were moved from a previous topic and the previous topic closed. The incident was marked as resolved by a few users, including Logan, but now it may have returned, so it needs to be tracked as a separate incident.

If others have the same issue, please reply to this post.

2 Likes

I’m still having the same issue for 2 days now.

Still having the issue, but not with every assistant, and often on second run after thread creation.

1 Like

I am having this issue too. Really long processing times.

Also still having an issue with really long processing times.

I am having substantial delays but not the endless queue like what was happening a few days ago. My response times are averaging at about 30s. Which is bad. But still functional. I’m struggling to understand why the Assistant api exists if it can’t replace chat completions. If it isn’t supposed to be for that, then they need to let us know. In theory it is cool, but in practice, nothing but trouble. Open AI needs to pump the breaks here, they rolled out garbage, the company almost collapsed and now they are behind the 8ball. I do appreciate the work and am not going anywhere, but if they expect this stuff to be enterprise level tech, the Assistant api IMHO is not hitting the mark here. Huge bummer. I’ll keep testing though. I do think that they made a mistake with the polling for response part of this. If anyone reads this, are you pausing between polls or just spamming the heck out of the endpoint? I’ve never heard of an api that requires this kind of interaction. Seems like a great way to overwhelm servers, especially when there is an army of copypasta coders out there just hammering away at this thing.

2 Likes

@scharleswatson I’m pausing 10-15 seconds between polls

I was also facing this issue. Not sure how to avoid this “queued”.
But how I deal with this is to wait until the run becomes “expired” (approx took 10 mins) then recreate & rerun the message.

Facing the same issue. It is perpetually in the queued state. Would appreciate this being solved as soon as possible. Also, the necessity of polling is insanity

Even I am facing the same issue. The run status gets stuck on the queue even if try on all of my assistants.

For me the severity of this issue has been reduced after being moved from Usage Tier 1 to Usage Tier 3, which was caused by my consistent usage history and buying more credits.

Rate limits are applied based on your usage tier, with limits on tokens and requests per minute.

Go to Platform Overview → Settings → Limits to see yours.

(correlation!=causation)

1 Like

I’m am seeing this issues as well. When I call an assistant that has tools it gets queued forever.

If the tool you are using is function calling, you might want to look at the JSON once. Adding the JSON and formatting it in the function calling might get a bit finicky sometimes and result in an invalid JSON format, and hence the assistant runs in a queue forever.

I fixed the JSON and the runs are working fine for me.

1 Like

Same problem.

Has anyone found solutions?

I have the same problem, The API seems to be stuck on Queue forever, the same assistant works fine on the open AI Playground

Come across this problem today too. The wired thing is every run I execute from the API it queue forever, but meantime all the runs executed on the Open AI playground worked smoothly, is there a preference from the Open AI to assign computational power?

Never mind I actually just found it’s my personal function mistake.