Always allow button not displayed

I’m building a custom GPT that calls an external API every once in a while, but each time it asks for user permission to make that call.

I want it to ask for permission once for the whole session, and never ask it again. But couldn’t do it.

I can see examples where there is “Always allow” button during Action calls, but somehow it doesn’t show up in my GPT’s API calls. Tried instructing the GPT to ask for it, tried isConsenquential flag, none of them worked.

(I use API key bearer auth model, not sure if it’s relevant. )

Any ideas how to make it work?

“Always allow” is only available for actions for which isConsequential is false.

This is not something you can set yourself, the model determines if it is consequential or not.

So, if your GPT is performing actions that gave consequences, the user will need to approve them every time.

1 Like

I see. I think this should be fixed and we should be given more control on this one. Probably OpenAI tries to protect the users, but it risks annoying them for GPTs built for specific purposes.

It could be a spelling issue, or maybe its in the wrong spot in your schema

I promise you, the need for user safety absolutely trumps convenience for GPT builders, so this would be considered a feature, not a bug, and not something that you should expect to change in the foreseeable future.