Android App Defaults to GPT-3.5 even though I'm a Plus User

Despite the fact that I am a Plus user, the app always defaults to GPT 3.5, so I have to manually switch to GPT-4/Browsing With Bing with each new conversation, which is extremely frustrating. Sometimes I forget to switch and I find myself chatting with the old dumb version before I realise it. What’s worse is that sometimes the app opens without the option to switch!

Anyone else is experiencing this issue?

I contacted support and received a generic troubleshooting response that doesn’t help at all. It seems that nobody even bothered to read my email.