Unable to load fine-tuning tools for GPT3

Hi, my names Jerome and i’m relatively inexperienced in coding. I’m doing a work attachment project to classify customers feedback. I am currently testing on Jupyter notebook but i ran into problems when starting to fine-tune a model. Here are the errors:

  1. !openai tools fine_tunes.prepare_data -f intent_sample.jsonl
  • this only works after i added -q at the end, which automatically agrees to any of the recommended changes to the json file but other than that it still faced the same issue(i)
  1. !openai api fine_tunes.create -t “intent_sample_prepared_train.jsonl” -v “intent_sample_prepared_valid.jsonl” -m ada

(i) my notebook just fails to run any other cells, was it some file directory issue or something else? Need helps welps

Welcome to the community.

Is it throwing any specific errors?

Nope, it is just stuck on (*)

Hrm. Could be code in the notebook. Where did you find it? Can you let us take a look?

Billing and everything up to date?

Hi, i followed this link but it is not working [Youtube-Tutorials/Youtube_GPT_3_Finetuning.ipynb at main · PradipNichite/Youtube-Tutorials · GitHub].

The following image is the code in my notebook:

It might take a while. Not sure how long you let it go.

Have you tried contacting that notebook’s author?

The last commit on that notebook was… " Latest commit 61a7bac Sep 12, 2022…"

Is this part running fine?

!pip install --upgrade openai

I vaguely remember a problem someone had with upgrading. You might want to search here in the forums too.

Also, you might want to check out what appears to be an official OpenAI notebook for fine-tuning…

Hope this helps.

i tried it on anaconda shell prompt and it works fine, thanks!

1 Like