Trying to use gpt-4 and langchain to generate blog posts. Failing miserably

Hello all,

I am trying to write a small python app that will generate blog posts on various topics. This app uses langchain to call the openai model. However, when I run this app, all I get as output is:

A detailed blog post about Tree of Thoughts could include sections such as “The Tree of Life Concept”, “Connect Your Own Models and Enjoy Superintelligence”, and “Share This Repository”. It could have a title such as “Tree of Thoughts (ToT): Code for Paper Tree of Thoughts: Deliberate Problem Solving with Large Language Models”.

In other words, the model isn’t creating a blog post. It’s just ruminating about how to create one.
Note that I’ve tried to do this with GPT-4 with browsing enabled, but it fails miserably as it can’t seem to read any links, so it doesn’t understand what ToT is as it was developed after the training cut-off date for GPT4.

I am at my wits end trying to figure out what’s wrong here.

Any help appreciated


I forgot to add the prompts that i am using:

  1. You have been given access to a search tool. Please gather
    information about the AI algorithm topic {topic}.

  2. Please create a title for a blog post on {topic}

  3. Using the title for {topic} Please create some
    blog sections for a blog post

  4. Please generate the content for section 1 of the blog
    post on topic {topic} .

  5.  Please expand the content for section 1 of the blog    
       post on topic {topic} into a detailed professional     

I’ll suggest you have a look at what @curt.kennedy made over here:

It’s very similar to what you’re trying to do, and does not have a langchain dependency :laughing:

1 Like

I don’t think that the problem is with langchain. It’s somthing to do with the model, I believe