Really surprising action behavior, have to share

So I made a basic to-do endpoint to test out actions. But I was having issues with the delete so I left that out of the api temporarily.

This morning I forgot that wasn’t implemented. When I asked my gpt to remove or delete an item, it worked!
I looked at the db - it had decided to change value of to-do’s I asked it delete to “(Removed)”, and then it automatically filtered the (Removes) out when I asked what the to-do list now was!

Once I fixed the delete method and replaced the api, it actually deleted the records from the db correctly.

This really amazes me, and brings up the interesting possibilities of self-healing code. Currently if the delete method existed but was throwing an error then it probably wouldn’t have worked at all, but it’s still very close.

Bill B

1 Like

Wait, are you saying you were able to edit the openapi schema in the natural language part of the the gpt ???

No, to add in the delete method I had to remove the action and replace it. Editing it does not seem to work, or at least didn’t.

This is like an app called ‘The Final App’. It is highly optimized and compressed AI system. Instead of preprograming its capabilities, the developers left it to itself to develope its own capabilities. For a time this will be with user guidance and to fulfill user desires, but the app really won’t need the user, for anything.