Paths section is not an object

I’m trying to get started on a plugin.
So is working on creating a simple wrapper on my api as an REST service and is using swagger-autogen - npm to then generate an openapi file

But when i try loading it, i get an “Paths section is not an object”
and then it shows Paths as an object below :-/

Anyone have an idea what the above error means ?

I found the best way to create the docs it to use the and exporting the YAML like that. I have never had a plugin error going this route.

Furthermore, make sure to have an operationId on each chatgpt facing endpoint on chatGPT will ignore the endpoint .

Embarresing. Found the issue 1 minute later. When testing I was loading the json file created, but when pushed to kubernetes I was using the module result. So the json was invalid, needed to only teturn the part in data property. Works now :blush:

I am getting the same error. I traced through all the conversation threads and tried using the API spec through swagger and convert to yaml. Still the same error. It is is indeed frustrating.
Wondering how @skadefro solved it.

Does your openapi.yaml validate successfully?

For a long time i kept getting different warnings, I could solve most of them, by making small changes to the manifest, but one kept showing up. I see they no longer raises warning for that, sorry I cannot remember what the last warning was.

1 Like