OpenAI not supporting request headers for ChatGPT Plugins? "parameter X has location header; ignoring"

Hey there!

When I add a plugin to ChatGPT (Plugin store → Develop your own plugin → Enter website domain), OpenAI validates my manifest and OpenAPI spec. The manifest looks alright. However, I receive the following warning for my OpenAPI spec: In path /X, method X, operationId X, parameter X has location header; ignoring

The relevant part of the OpenAPI spec:

  "paths": {
    "/X": {
      "X": {
        "operationId": "X",
        "parameters": [
            "in": "header",
            "name": "X",
            "schema": {
              "type": "string"
            "required": true,
            "description": "X"

My question: Does OpenAI not support headers in OpenAPI specs from ChatGPT plugins or am I missing something here? I checked the official OpenAPI spec documentation which OpenAI also referred to in their ChatGPT docs and my spec looks alright: OpenAPI Specification - Version 3.0.3 | Swagger

Any help is much appreciated!


Have you tried pasting the spec into chatGPT and asking it to critique?
Aside - is that an official plugin api spec? this is the openai link I’m aware of:

1 Like

Thanks! Yes, I already asked ChatGPT and went through the official docs you linked, both didn’t help, unfortunately.

1 Like

I have the same problem the API that I want ChatGPT to use has required Headers but when I use the openapi.yaml file it shows this warning and the headers are ignored. This prevents me from being able to develop or test my plugin. Appreciate your help! thanks

Hi @shawkat.kabbara As we experienced this issue ourselves, we added support for custom request headers at Langdock which fixed it for us and our users. At Langdock, we’re building an open-source platform to create, deploy, test, and monitor ChatGPT and LangChain plugins. Let me know if you want to learn more.

Hi all!
I was getting the same error but we specified it a bit differently to avoid this error.
Nevertheless as you can see we have specified on the left a couple of request headers which are required but this is not respected and on the right you can see the request being sent without those headers which result in an error (expected when headers are missing). Any updates on this ?