My fine tune model is not working through API request but working fine on playground

I fine-tuned a DaVinci model for my project, but I cannot access it through an API request. And the strange thing is it’s working completely fine on Openai playground. Can any please help?

Use the fine-tune retrieve API method to get the full details of your fine-tune object and inspect it:


Retrieve Fine-Tune

I tried to run the below command to get the list of my fine-tuned model to fetch the fine_tune_id, but it’s responding as empty data list.

So, you have no fine-tuned models at all in your account?

yes, but if you will see my playground it’s working fine over there.

That means you have a problem with your code which calls the API method.


If it’s true, then how is my code working completely fine with calling an untrained basic model?

No idea about your code since we cannot see it.

FWIW, I have many fine-tuned models and the models all match perfectly between the API and Playground.

Never had a problem.


Issue Solved!! The reason for that was somehow, my personal account got merged with my working account, and I hadn’t mentioned the organization id (openai.organization) before making the request to openai.